aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/newt
diff options
context:
space:
mode:
authorKai Kang <kai.kang@windriver.com>2015-02-12 16:26:07 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-02-14 22:26:11 +0000
commit9963b22acacbe49bffd7ebdeb72c45280e687385 (patch)
treea5c8e014d220ebabbf5abb886f1eb7d2fe93dd91 /meta/recipes-extended/newt
parent0d5103997afef773376df01260f0d52555e2a9cd (diff)
downloadopenembedded-core-9963b22acacbe49bffd7ebdeb72c45280e687385.tar.gz
libnewt-python: remove make var LIBNEWTSH
Var LIBNEWTSH which points to libnewt.so in STAGING_LIBDIR is passed to make. But during do_compile, LIBNEWTSH is rebuilt. Check the log that gcc populates file into STAGING_LIBDIR directly: i586-poky-linux-gcc -m32 -march=i586 --sysroot=/poky/builds/build/tmp/sysroots/qemux86 -shared -o /poky/builds/build/tmp/sysroots/qemux86/usr/lib/libnewt.so.0.52.18 ... It is not a proper operation export file into STAGING_LIBDIR during compile. So remove the var LIBNEWTSH. Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-extended/newt')
-rw-r--r--meta/recipes-extended/newt/libnewt-python_0.52.18.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-extended/newt/libnewt-python_0.52.18.bb b/meta/recipes-extended/newt/libnewt-python_0.52.18.bb
index d591fbd3d2..ecc670e0aa 100644
--- a/meta/recipes-extended/newt/libnewt-python_0.52.18.bb
+++ b/meta/recipes-extended/newt/libnewt-python_0.52.18.bb
@@ -12,7 +12,7 @@ EXTRA_OEMAKE += "PYTHONVERS=${PYTHON_DIR}"
do_compile () {
VERSION="$(sed -n 's/^VERSION = //p' Makefile)"
- oe_runmake "LIBNEWTSH=${STAGING_LIBDIR}/libnewt.so.$VERSION" _snack.so
+ oe_runmake _snack.so
}
do_install () {