summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/net-tools
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2012-04-15 17:06:47 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-04-15 17:31:05 +0100
commit1cfddb17e0c2576e55f62c10612e7cbd73e5ac5e (patch)
tree85067f9026c85493400a2b0709bd3fcbbf7204d6 /meta/recipes-extended/net-tools
parent06f6ca50c0cffdaf828688e01fcc70265eafa093 (diff)
downloadopenembedded-core-1cfddb17e0c2576e55f62c10612e7cbd73e5ac5e.tar.gz
net-tools: Fix do_patch to be re-executable
This recipe's do_patch was not able to be re-executed due to its custom patching functions. This fixes things so that it can be re-executed. It also fixes the unpack task re-execution by ensuring ${S} is clean before the unpack starts. [YOCTO #2194] Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/net-tools')
-rw-r--r--meta/recipes-extended/net-tools/net-tools_1.60-23.bb12
1 files changed, 10 insertions, 2 deletions
diff --git a/meta/recipes-extended/net-tools/net-tools_1.60-23.bb b/meta/recipes-extended/net-tools/net-tools_1.60-23.bb
index 213fb6075c..c8d2c57923 100644
--- a/meta/recipes-extended/net-tools/net-tools_1.60-23.bb
+++ b/meta/recipes-extended/net-tools/net-tools_1.60-23.bb
@@ -31,11 +31,19 @@ PARALLEL_MAKE = ""
# up all previously applied patches in the start
nettools_do_patch() {
cd ${S}
- patch -p1 < ${WORKDIR}/${BPN}_${PV}.diff
+ quilt pop -a || true
+ if [ -d ${S}/.pc-nettools ]; then
+ mv ${S}/.pc-nettools ${S}/.pc
+ QUILT_PATCHES=${S}/debian/patches quilt pop -a
+ rm -rf ${S}/.pc ${S}/debian
+ fi
+ patch -p1 < ${WORKDIR}/${BPN}_${PV}.diff
QUILT_PATCHES=${S}/debian/patches quilt push -a
- rm -rf ${S}/patches ${S}/.pc
+ mv ${S}/.pc ${S}/.pc-nettools
}
+do_unpack[cleandirs] += "${S}"
+
# We invoke base do_patch at end, to incorporate any local patch
python do_patch() {
bb.build.exec_func('nettools_do_patch', d)