aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/mktemp
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2012-07-26 17:00:54 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-08-15 14:18:40 +0100
commit4807d938023ce06f2924c8a0503c32d083be23b5 (patch)
tree85540c11a493b5a128504f56c8d53e476bb3eeaf /meta/recipes-extended/mktemp
parentc8344dd884e19144576c994766e49e230c7eca13 (diff)
downloadopenembedded-core-4807d938023ce06f2924c8a0503c32d083be23b5.tar.gz
mktemp: cleanup update-alternatives deprecated code
Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-extended/mktemp')
-rw-r--r--meta/recipes-extended/mktemp/mktemp_1.7.bb11
1 files changed, 5 insertions, 6 deletions
diff --git a/meta/recipes-extended/mktemp/mktemp_1.7.bb b/meta/recipes-extended/mktemp/mktemp_1.7.bb
index b3a3d51afa..170a183a6e 100644
--- a/meta/recipes-extended/mktemp/mktemp_1.7.bb
+++ b/meta/recipes-extended/mktemp/mktemp_1.7.bb
@@ -5,7 +5,7 @@ SECTION = "console/utils"
LICENSE = "ISC"
LIC_FILES_CHKSUM = "file://LICENSE;md5=430680f6322a1eb87199b5e01a82c0d4"
-PR = "r2"
+PR = "r3"
SRC_URI = "ftp://ftp.mktemp.org/pub/mktemp/${BPN}-${PV}.tar.gz \
file://disable-strip.patch \
@@ -20,12 +20,11 @@ inherit autotools update-alternatives
EXTRA_OECONF = "--with-libc"
do_install_append () {
- mkdir ${D}${base_bindir}
- mv ${D}${bindir}/mktemp ${D}${base_bindir}/mktemp.${BPN}
+ install -d ${D}${base_bindir}
+ mv ${D}${bindir}/mktemp ${D}${base_bindir}/mktemp
rmdir ${D}${bindir}
}
-ALTERNATIVE_NAME = "mktemp"
-ALTERNATIVE_LINK = "${base_bindir}/mktemp"
-ALTERNATIVE_PATH = "${base_bindir}/mktemp.${BPN}"
+ALTERNATIVE_${PN} = "mktemp"
+ALTERNATIVE_LINK_NAME[mktemp] = "${base_bindir}/mktemp"
ALTERNATIVE_PRIORITY = "100"