summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/mdadm
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2012-06-17 17:13:07 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-06-18 13:16:37 +0100
commit5b51872ec4c2400ae60f434478f04e9aca3ccb7d (patch)
treee74cf8713736bc7a43d3450d350aca3eec69b9cc /meta/recipes-extended/mdadm
parent45b40d483c675369cdc164babd0db5c87adf0de4 (diff)
downloadopenembedded-core-5b51872ec4c2400ae60f434478f04e9aca3ccb7d.tar.gz
mdadm: Don't depend on ansidecl.h header
We don't DEPEND on binutils for ansidecl.h so ensure we should never use the header. This makes builds determinstic and means something like: bitbake binutils bitbake mdadm -c compile bitbake binutils -c clean bitbake libxml2 doen't fail to build. Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-extended/mdadm')
-rw-r--r--meta/recipes-extended/mdadm/mdadm_3.2.5.bb7
1 files changed, 6 insertions, 1 deletions
diff --git a/meta/recipes-extended/mdadm/mdadm_3.2.5.bb b/meta/recipes-extended/mdadm/mdadm_3.2.5.bb
index 2d7e1d036f..61846f4d77 100644
--- a/meta/recipes-extended/mdadm/mdadm_3.2.5.bb
+++ b/meta/recipes-extended/mdadm/mdadm_3.2.5.bb
@@ -8,7 +8,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
file://mdmon.c;beginline=4;endline=18;md5=af7d8444d9c4d3e5c7caac0d9d34039d \
file://mdadm.h;beglinlne=4;endline=22;md5=462bc9936ac0d3da110191a3f9994161"
-PR = "r0"
+PR = "r1"
SRC_URI = "${KERNELORG_MIRROR}/linux/utils/raid/mdadm/${BPN}-${PV}.tar.bz2 \
file://mdadm-3.2.2_fix_for_x32.patch \
@@ -21,6 +21,11 @@ CFLAGS += "-fno-strict-aliasing"
inherit autotools
+# We don't DEPEND on binutils for ansidecl.h so ensure we don't use the header
+do_configure_prepend () {
+ sed -i -e '/.*ansidecl.h.*/d' ${S}/sha1.h
+}
+
do_compile() {
oe_runmake
}