aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/man-pages
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2014-10-29 13:54:49 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-11-04 10:20:34 +0000
commit32357da67fa640bc0c14048af1d7b8dbbe8e775e (patch)
treed8a7afff3dbe54e004c0d08c21bede95b938a202 /meta/recipes-extended/man-pages
parent8548868c05e52700fd4712298b1705b8ec7ae446 (diff)
downloadopenembedded-core-32357da67fa640bc0c14048af1d7b8dbbe8e775e.tar.gz
man-pages/shadow: resolve man pages confliction
Invoke smart/rpm to install man-pages and shadow-doc, there is a build failure: ... |error: file /usr/share/man/man5/passwd.5 from install of shadow-doc-4.2.1-r0.0.core2_64 conflicts with file from package man-pages-3.70-r0.0.core2_64 |error: file /usr/share/man/man3/getspnam.3 from install of shadow-doc-4.2.1-r0.0.core2_64 conflicts with file from package man-pages-3.70-r0.0.core2_64 ... Use alternatives mechanism to fix it. As README in man-pages said: "Note that sometimes these pages are duplicates of pages also distributed in other packages. Be careful not to overwrite more up-to-date versions. So we set man-pages with lower priority. [YOCTO #6769] Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-extended/man-pages')
-rw-r--r--meta/recipes-extended/man-pages/man-pages_3.71.bb7
1 files changed, 7 insertions, 0 deletions
diff --git a/meta/recipes-extended/man-pages/man-pages_3.71.bb b/meta/recipes-extended/man-pages/man-pages_3.71.bb
index 759bad540c..225b2567cb 100644
--- a/meta/recipes-extended/man-pages/man-pages_3.71.bb
+++ b/meta/recipes-extended/man-pages/man-pages_3.71.bb
@@ -27,3 +27,10 @@ do_install() {
# Only deliveres man-pages so FILES_${PN} gets everything
FILES_${PN}-doc = ""
FILES_${PN} = "${mandir}/*"
+
+inherit update-alternatives
+
+ALTERNATIVE_PRIORITY = "100"
+ALTERNATIVE_${PN} = "passwd.5 getspnam.3"
+ALTERNATIVE_LINK_NAME[passwd.5] = "${mandir}/man5/passwd.5"
+ALTERNATIVE_LINK_NAME[getspnam.3] = "${mandir}/man3/getspnam.3"