aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/lsof
diff options
context:
space:
mode:
authorJason Wessel <jason.wessel@windriver.com>2012-06-12 16:42:31 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-06-13 11:42:46 +0100
commit5c257ee55f9e0dd66fc1bbd6e9c08918e8820178 (patch)
tree54f82063386e20bcd910227b19a924b12d2914ee /meta/recipes-extended/lsof
parent6f0d830ed047f700702645d454054dfd6fea6f25 (diff)
downloadopenembedded-core-5c257ee55f9e0dd66fc1bbd6e9c08918e8820178.tar.gz
lsof: Fix cross 32 -> 64bit ranlib host contamination problem
When building on a 32bit host OS and building 64 bit binaries, the cross ar and ranlib must be called, or you get an error as follows: x86_64-wrs-linux-gcc -m64 --sysroot=/opt/build/tmp/sysroots/qemux86-64 -o lsof dfile.o dmnt.o dnode.o dproc.o dsock.o dstore.o arg.o main.o misc.o node.o print.o proc.o store.o usage.o util.o -Wl,-O1 -Wl,--hash-style=gnu -Wl,--as-needed -L./lib -llsof ./lib/liblsof.a: could not read symbols: Archive has no index; run ranlib to add one collect2: error: ld returned 1 exit status Signed-off-by: Jason Wessel <jason.wessel@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/lsof')
-rw-r--r--meta/recipes-extended/lsof/lsof_4.85.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta/recipes-extended/lsof/lsof_4.85.bb b/meta/recipes-extended/lsof/lsof_4.85.bb
index 8f25e24a50..58237256af 100644
--- a/meta/recipes-extended/lsof/lsof_4.85.bb
+++ b/meta/recipes-extended/lsof/lsof_4.85.bb
@@ -3,7 +3,7 @@ DESCRIPTION = "Lsof is a Unix-specific diagnostic tool. \
Its name stands for LiSt Open Files, and it does just that."
SECTION = "devel"
LICENSE = "BSD"
-PR = "r0"
+PR = "r1"
SRC_URI = "ftp://lsof.itap.purdue.edu/pub/tools/unix/lsof/lsof_${PV}.tar.bz2"
@@ -29,6 +29,8 @@ LSOF_OS_libc-glibc = "linux"
export LSOF_INCLUDE = "${STAGING_INCDIR}"
do_configure () {
+ export LSOF_AR="${AR} cr"
+ export LSOF_RANLIB="${RANLIB}"
yes | ./Configure ${LSOF_OS}
}