aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/lsb
diff options
context:
space:
mode:
authorCristian Iorga <cristian.iorga@intel.com>2013-04-01 10:34:45 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-04-02 18:09:30 +0100
commitddd43fcdb8af7d5b1a64d2c6cbd72a3896869321 (patch)
tree86254890bba31536980b25d1e8597ffe399e59c2 /meta/recipes-extended/lsb
parentaee67a229304827a12b7776a82fb1c320da9a3c4 (diff)
downloadopenembedded-core-ddd43fcdb8af7d5b1a64d2c6cbd72a3896869321.tar.gz
lsb: distro codename info added
Poky distro codename info added to /etc/lsb-release file. lsb_release script will not complain anymore about the incompleteness of /etc/lsb-release file by returning an error code. Increases LSB compliance. Partial fix for [YOCTO #4071]. Signed-off-by: Cristian Iorga <cristian.iorga@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/lsb')
-rw-r--r--meta/recipes-extended/lsb/lsb_4.1.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/meta/recipes-extended/lsb/lsb_4.1.bb b/meta/recipes-extended/lsb/lsb_4.1.bb
index 01368b334b..59d5bcafef 100644
--- a/meta/recipes-extended/lsb/lsb_4.1.bb
+++ b/meta/recipes-extended/lsb/lsb_4.1.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "LSB support for OpenEmbedded"
SECTION = "console/utils"
HOMEPAGE = "http://prdownloads.sourceforge.net/lsb"
LICENSE = "GPLv2+"
-PR = "r1"
+PR = "r2"
# lsb_release needs getopt
RDEPENDS_${PN} += "util-linux"
@@ -41,6 +41,9 @@ do_install(){
echo "\"" >> ${D}${sysconfdir}/lsb-release
echo "DISTRIB_ID=${DISTRO}" >> ${D}${sysconfdir}/lsb-release
echo "DISTRIB_RELEASE=${DISTRO_VERSION}" >> ${D}${sysconfdir}/lsb-release
+ if [ -n "${DISTRO_CODENAME}" ]; then
+ echo "DISTRIB_CODENAME=${DISTRO_CODENAME}" >> ${D}${sysconfdir}/lsb-release
+ fi
echo "DISTRIB_DESCRIPTION=\"${DISTRO_NAME} ${DISTRO_VERSION}\"" >> ${D}${sysconfdir}/lsb-release
if [ "${TARGET_ARCH}" = "i586" ];then