aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/lsb
diff options
context:
space:
mode:
authorStefan Stanacar <stefanx.stanacar@intel.com>2014-03-11 15:40:09 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-03-11 20:24:03 -0700
commitc90d1047c41148cbd57f26b5a34563346602a71b (patch)
tree35622569adbef117d3ed9d1731bb547a579169a4 /meta/recipes-extended/lsb
parent9b22b32863f9110522362706a28036cc945201d5 (diff)
downloadopenembedded-core-c90d1047c41148cbd57f26b5a34563346602a71b.tar.gz
lsbtest: fix comparison bashism
== is a bashism use = instead. Signed-off-by: Stefan Stanacar <stefanx.stanacar@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/lsb')
-rw-r--r--meta/recipes-extended/lsb/lsbtest/LSB_Test.sh4
-rw-r--r--meta/recipes-extended/lsb/lsbtest_1.0.bb8
2 files changed, 6 insertions, 6 deletions
diff --git a/meta/recipes-extended/lsb/lsbtest/LSB_Test.sh b/meta/recipes-extended/lsb/lsbtest/LSB_Test.sh
index 12f00547ae..ab79985b1b 100644
--- a/meta/recipes-extended/lsb/lsbtest/LSB_Test.sh
+++ b/meta/recipes-extended/lsb/lsbtest/LSB_Test.sh
@@ -272,12 +272,12 @@ then
fi
if ! `grep -F -q "noarch-suse" ${PLATFORM_FILE}`; then
- if [ ${ARCH} == i686 ];then
+ if [ ${ARCH} = i686 ];then
echo "i486-suse" >> ${PLATFORM_FILE}
echo "i486-noarch" >> ${PLATFORM_FILE}
echo "i486-pc" >> ${PLATFORM_FILE}
echo "noarch-suse" >> ${PLATFORM_FILE}
- elif [ ${ARCH} == x86_64 ]; then
+ elif [ ${ARCH} = x86_64 ]; then
echo "i486-suse" >> ${PLATFORM_FILE}
echo "i486-noarch" >> ${PLATFORM_FILE}
echo "i486-pc" >> ${PLATFORM_FILE}
diff --git a/meta/recipes-extended/lsb/lsbtest_1.0.bb b/meta/recipes-extended/lsb/lsbtest_1.0.bb
index a877beb299..f61251e2aa 100644
--- a/meta/recipes-extended/lsb/lsbtest_1.0.bb
+++ b/meta/recipes-extended/lsb/lsbtest_1.0.bb
@@ -19,15 +19,15 @@ do_install() {
install -d ${D}/opt/lsb-test
install -m 0644 ${S}/packages_list ${D}/opt/lsb-test/packages_list
install -m 0644 ${S}/session ${D}/opt/lsb-test/session
- if [ "${TARGET_ARCH}" == "i586" ];then
+ if [ "${TARGET_ARCH}" = "i586" ];then
sed -i -e 's/lsbarch/ia32/g' -e 's/targetarch/i486/g' ${D}/opt/lsb-test/packages_list
sed -i -e 's/targetarch/x86/g' ${D}/opt/lsb-test/session
fi
- if [ "${TARGET_ARCH}" == "x86_64" ];then
+ if [ "${TARGET_ARCH}" = "x86_64" ];then
sed -i -e 's/lsbarch/amd64/g' -e 's/targetarch/x86_64/g' ${D}/opt/lsb-test/packages_list
sed -i -e 's/targetarch/x86-64/g' ${D}/opt/lsb-test/session
fi
- if [ "${TARGET_ARCH}" == "powerpc" ];then
+ if [ "${TARGET_ARCH}" = "powerpc" ];then
sed -i -e 's/lsbarch/ppc32/g' -e 's/targetarch/ppc/g' ${D}/opt/lsb-test/packages_list
sed -i -e 's/targetarch/PPC32/g' ${D}/opt/lsb-test/session
fi
@@ -37,7 +37,7 @@ do_install() {
# in the package_list when MLIB=lib64 is being used.
# Otherwise, by default, the ppc32 LSB packages
# will be downloaded by LSB_Test.sh
- if [ "${TARGET_ARCH}" == "powerpc64" ];then
+ if [ "${TARGET_ARCH}" = "powerpc64" ];then
if [ "${PN}" != "${BPN}" ];then
sed -i -e 's/lsbarch/ppc64/g' -e 's/targetarch/ppc64/g' ${D}/opt/lsb-test/packages_list
sed -i -e 's/targetarch/PPC64/g' ${D}/opt/lsb-test/session