aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/lsb
diff options
context:
space:
mode:
authorJavier Martinez Canillas <javier@dowhile0.org>2012-08-05 21:48:33 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-08-06 14:18:56 +0100
commit0a8003a3542d17332488ca715619990b222ceb71 (patch)
treec2cebf3172ddf2b8e8a644031229714477e21f0c /meta/recipes-extended/lsb
parenta9c73d9d3dd5f7fbee82d7ed3cb88a80aa3cbfbd (diff)
downloadopenembedded-core-0a8003a3542d17332488ca715619990b222ceb71.tar.gz
lsbtest: use ${bindir} instead of /usr/bin for packaging
It is considered good practice to use the build system provided variables instead of directly specify hardcoded paths. Signed-off-by: Javier Martinez Canillas <javier@dowhile0.org> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/lsb')
-rw-r--r--meta/recipes-extended/lsb/lsbtest_1.0.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta/recipes-extended/lsb/lsbtest_1.0.bb b/meta/recipes-extended/lsb/lsbtest_1.0.bb
index 11911643b5..5ebea53202 100644
--- a/meta/recipes-extended/lsb/lsbtest_1.0.bb
+++ b/meta/recipes-extended/lsb/lsbtest_1.0.bb
@@ -1,7 +1,7 @@
DESCRIPTION = "automate test for lsb"
SECTION = "console/utils"
LICENSE = "GPLv2"
-PR = "r0"
+PR = "r1"
LIC_FILES_CHKSUM = "file://LSB_Test.sh;beginline=3;endline=16;md5=7063bb54b04719df0716b513447f4fc0"
@@ -14,8 +14,8 @@ RDEPENDS_${PN} = "rpm"
S = "${WORKDIR}"
do_install() {
- install -d ${D}/usr/bin
- install -m 0755 ${S}/LSB_Test.sh ${D}/usr/bin
+ install -d ${D}${bindir}
+ install -m 0755 ${S}/LSB_Test.sh ${D}${bindir}
install -d ${D}/opt/lsb-test
install -m 0644 ${S}/packages_list ${D}/opt/lsb-test/packages_list
install -m 0644 ${S}/session ${D}/opt/lsb-test/session