aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/logrotate/logrotate_3.8.1.bb
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2012-03-14 17:55:17 +0800
committerSaul Wold <sgw@linux.intel.com>2012-03-19 00:05:17 -0700
commit9dc1a8c793e1908032be0f0ea3b3f0832b1bf5aa (patch)
tree4d8e93b4184fde0752ff7be91a8a3a55a2c41a10 /meta/recipes-extended/logrotate/logrotate_3.8.1.bb
parent2ec5f1eab1f3d2eeff9f3984654a3fb4d87679e7 (diff)
downloadopenembedded-core-9dc1a8c793e1908032be0f0ea3b3f0832b1bf5aa.tar.gz
upgrade logrotate: update the recipe
update the recipe: ogrotate_3.7.9.bb -> logrotate_3.8.1.bb Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Diffstat (limited to 'meta/recipes-extended/logrotate/logrotate_3.8.1.bb')
-rw-r--r--meta/recipes-extended/logrotate/logrotate_3.8.1.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta/recipes-extended/logrotate/logrotate_3.8.1.bb b/meta/recipes-extended/logrotate/logrotate_3.8.1.bb
new file mode 100644
index 0000000000..5a8156be57
--- /dev/null
+++ b/meta/recipes-extended/logrotate/logrotate_3.8.1.bb
@@ -0,0 +1,34 @@
+DESCRIPTION = "Rotates, compresses, removes and mails system log files"
+SECTION = "console/utils"
+HOMEPAGE = "https://fedorahosted.org/releases/l/o/logrotate"
+LICENSE = "GPLv2"
+PR = "r0"
+
+DEPENDS="coreutils popt"
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=18810669f13b87348459e611d31ab760"
+
+SRC_URI = "https://fedorahosted.org/releases/l/o/logrotate/logrotate-${PV}.tar.gz \
+ file://act-as-mv-when-rotate.patch \
+ file://disable-check-different-filesystems.patch \
+ file://update-the-manual.patch \
+ "
+
+SRC_URI[md5sum] = "bd2e20d8dc644291b08f9215397d28a5"
+SRC_URI[sha256sum] = "c12471e70ae8bc923bd5c4f25e8fd6483b68c6301f3cd79f7cfe37bc5b370169"
+
+
+EXTRA_OEMAKE = "CC='${CC}'"
+
+do_install(){
+ oe_runmake install DESTDIR=${D} PREFIX=${D} MANDIR=${mandir}
+}
+
+do_install_append(){
+ mkdir -p ${D}${sysconfdir}/logrotate.d
+ mkdir -p ${D}${sysconfdir}/cron.daily
+ mkdir -p ${D}${localstatedir}/lib
+ install -p -m 644 examples/logrotate-default ${D}${sysconfdir}/logrotate.conf
+ install -p -m 755 examples/logrotate.cron ${D}${sysconfdir}/cron.daily/logrotate
+ touch ${D}${localstatedir}/lib/logrotate.status
+}