aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/iptables
diff options
context:
space:
mode:
authorShane Wang <shane.wang@intel.com>2012-01-21 22:27:32 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-01-24 11:23:57 +0000
commit27ed7024cf2ee9c9f84246fd931bc390cb638851 (patch)
tree206350417b9f4c95f1b0fa0cc9505b6a05b2a64f /meta/recipes-extended/iptables
parenta04c89e4e2a5f98716001ba9e5e25b21323f4606 (diff)
downloadopenembedded-core-27ed7024cf2ee9c9f84246fd931bc390cb638851.tar.gz
iptables: upgrade to 1.4.12.2
This patch is to upgrade iptables to 1.4.12.2, and introduce a patch not to check unknown symbols. Otherwise, when it is compiled, it will report "libxtables.so.7" from LD_PRELOAD cannot be preloaded. Signed-off-by: Shane Wang <shane.wang@intel.com>
Diffstat (limited to 'meta/recipes-extended/iptables')
-rw-r--r--meta/recipes-extended/iptables/iptables/GNUmakefile.patch18
-rw-r--r--meta/recipes-extended/iptables/iptables_1.4.12.2.bb (renamed from meta/recipes-extended/iptables/iptables_1.4.12.1.bb)7
2 files changed, 22 insertions, 3 deletions
diff --git a/meta/recipes-extended/iptables/iptables/GNUmakefile.patch b/meta/recipes-extended/iptables/iptables/GNUmakefile.patch
new file mode 100644
index 0000000000..c60e84f0a2
--- /dev/null
+++ b/meta/recipes-extended/iptables/iptables/GNUmakefile.patch
@@ -0,0 +1,18 @@
+Don't check unknown symbols.
+
+Signed-off-by: Shane Wang <shane.wang@intel.com>
+
+Upstream-Status: Inappropriate [configuration]
+
+diff -r abb89394ce0c extensions/GNUmakefile.in
+--- a/extensions/GNUmakefile.in Mon Jan 23 00:12:27 2012 +0800
++++ b/extensions/GNUmakefile.in Mon Jan 23 00:38:32 2012 +0800
+@@ -68,7 +68,7 @@
+
+ .PHONY: all install clean distclean FORCE
+
+-all: ${targets} check
++all: ${targets}
+
+ check: ${targets}
+ @echo " CHECK unknown symbols in .so files"; \
diff --git a/meta/recipes-extended/iptables/iptables_1.4.12.1.bb b/meta/recipes-extended/iptables/iptables_1.4.12.2.bb
index 52aa4d52c9..2d3d3113bb 100644
--- a/meta/recipes-extended/iptables/iptables_1.4.12.1.bb
+++ b/meta/recipes-extended/iptables/iptables_1.4.12.2.bb
@@ -21,10 +21,11 @@ RRECOMMENDS_${PN} = "kernel-module-x-tables \
FILES_${PN} =+ "${libdir}/xtables/"
FILES_${PN}-dbg =+ "${libdir}/xtables/.debug"
-SRC_URI = "http://netfilter.org/projects/iptables/files/iptables-${PV}.tar.bz2"
+SRC_URI = "http://netfilter.org/projects/iptables/files/iptables-${PV}.tar.bz2 \
+ file://GNUmakefile.patch"
-SRC_URI[md5sum] = "b08a1195ec2c1ebeaf072db3c55fdf43"
-SRC_URI[sha256sum] = "77e6581f21f15946a814fa311236e5f3f7c6593180f9d695cea06aa95e464aba"
+SRC_URI[md5sum] = "212112389c7f10c72efb31a4ed193a4c"
+SRC_URI[sha256sum] = "09fff7dfe6af95675474fd5d0fc67622fac5a0f3d6e02ee614deae9a2e5dae13"
inherit autotools