aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/images
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2012-08-31 10:45:58 +0100
committerSaul Wold <sgw@linux.intel.com>2012-09-03 22:52:52 -0700
commit592d6e602466628d10704835a7b07d3d713f58e1 (patch)
treef79c78d93cc303bd5c24d83215ec130cd89f3509 /meta/recipes-extended/images
parentdbbcc0cb9d2cbc66027c800075b94eb9b7110a00 (diff)
downloadopenembedded-core-592d6e602466628d10704835a7b07d3d713f58e1.tar.gz
packagegroup-core-console: remove
This provides one package group, packagegroup-core-apps-console, which is usually brought in by adding "apps-console-core" to IMAGE_FEATURES. Aside from the naming inconsistencies, this is a group of mostly unrelated packages, none of which are actually "apps". Handling each one: * dbus: should mostly be brought in by package runtime dependencies * avahi-daemon: if you are using packagegroup-base (as all images that inherit from core-image do) this is brought in by having "zeroconf" in DISTRO_FEATURES. * portmap: not very useful by itself; should be brought in by selecting NFS server/client through other means. * psplash (or whatever SPLASH is set to): this has been changed to be an explicit item "splash" in IMAGE_FEATURES. Since this is a fairly fundamental feature, a piece of code has been added to automatically handle this for images still using apps-console-core (and show a warning). Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-extended/images')
-rw-r--r--meta/recipes-extended/images/core-image-basic.bb2
-rw-r--r--meta/recipes-extended/images/core-image-lsb-dev.bb2
-rw-r--r--meta/recipes-extended/images/core-image-lsb-sdk.bb2
-rw-r--r--meta/recipes-extended/images/core-image-lsb.bb2
4 files changed, 4 insertions, 4 deletions
diff --git a/meta/recipes-extended/images/core-image-basic.bb b/meta/recipes-extended/images/core-image-basic.bb
index 9aa880ec4f..06f15a8bec 100644
--- a/meta/recipes-extended/images/core-image-basic.bb
+++ b/meta/recipes-extended/images/core-image-basic.bb
@@ -1,7 +1,7 @@
DESCRIPTION = "A foundational basic image without support for X that can be \
reasonably used for customization."
-IMAGE_FEATURES += "apps-console-core ssh-server-openssh"
+IMAGE_FEATURES += "splash ssh-server-openssh"
IMAGE_INSTALL = "\
packagegroup-core-boot \
diff --git a/meta/recipes-extended/images/core-image-lsb-dev.bb b/meta/recipes-extended/images/core-image-lsb-dev.bb
index 557259b1b6..013efb973d 100644
--- a/meta/recipes-extended/images/core-image-lsb-dev.bb
+++ b/meta/recipes-extended/images/core-image-lsb-dev.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "Basic image without X support suitable for development work. It \
can be used for customization and implementations that conform to Linux \
Standard Base (LSB)."
-IMAGE_FEATURES += "apps-console-core dev-pkgs ssh-server-openssh"
+IMAGE_FEATURES += "splash dev-pkgs ssh-server-openssh"
IMAGE_INSTALL = "\
${CORE_IMAGE_BASE_INSTALL} \
diff --git a/meta/recipes-extended/images/core-image-lsb-sdk.bb b/meta/recipes-extended/images/core-image-lsb-sdk.bb
index d07f90d527..abddb767c6 100644
--- a/meta/recipes-extended/images/core-image-lsb-sdk.bb
+++ b/meta/recipes-extended/images/core-image-lsb-sdk.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "Basic image without X support suitable for Linux Standard Base \
(LSB) implementations. It includes the full meta-toolchain, plus development \
headers and libraries to form a standalone SDK."
-IMAGE_FEATURES += "apps-console-core tools-sdk dev-pkgs ssh-server-openssh \
+IMAGE_FEATURES += "splash tools-sdk dev-pkgs ssh-server-openssh \
tools-debug tools-profile tools-testapps debug-tweaks"
diff --git a/meta/recipes-extended/images/core-image-lsb.bb b/meta/recipes-extended/images/core-image-lsb.bb
index 8435596da1..2c47dc6b09 100644
--- a/meta/recipes-extended/images/core-image-lsb.bb
+++ b/meta/recipes-extended/images/core-image-lsb.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "A foundational basic image without support for X that can be \
reasonably used for customization and is suitable for implementations that \
conform to Linux Standard Base (LSB)."
-IMAGE_FEATURES += "apps-console-core ssh-server-openssh"
+IMAGE_FEATURES += "splash ssh-server-openssh"
IMAGE_INSTALL = "\
${CORE_IMAGE_BASE_INSTALL} \