summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/hdparm
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@windriver.com>2012-04-13 18:41:08 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-04-24 11:38:17 +0100
commita9b046297c10ca2b2368012803cd719ff59292d7 (patch)
treec77e6ca276dc2f0fc7365a787b0bc016096b2cbe /meta/recipes-extended/hdparm
parent4a4c568e25a08e9f222d723f9819582c9f895c58 (diff)
downloadopenembedded-core-a9b046297c10ca2b2368012803cd719ff59292d7.tar.gz
hdparm: Use update-alternatives
Switch to using update-alternatives, this ensures that the call to update-alternatives and package provides are correct. Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
Diffstat (limited to 'meta/recipes-extended/hdparm')
-rw-r--r--meta/recipes-extended/hdparm/hdparm_9.39.bb16
1 files changed, 6 insertions, 10 deletions
diff --git a/meta/recipes-extended/hdparm/hdparm_9.39.bb b/meta/recipes-extended/hdparm/hdparm_9.39.bb
index ed076cc29e..42867a90d3 100644
--- a/meta/recipes-extended/hdparm/hdparm_9.39.bb
+++ b/meta/recipes-extended/hdparm/hdparm_9.39.bb
@@ -8,7 +8,7 @@ LIC_FILES_CHKSUM = "file://LICENSE.TXT;md5=910a8a42c962d238619c75fdb78bdb24 \
file://wiper/GPLv2.txt;md5=fcb02dc552a041dee27e4b85c7396067 \
file://wiper/wiper.sh;beginline=7;endline=31;md5=b7bc642addc152ea307505bf1a296f09"
-PR = "r1"
+PR = "r2"
PACKAGES += "wiper"
@@ -24,17 +24,13 @@ SRC_URI[sha256sum] = "72d550af4526aa96f0841c79321a0ee39d636cbaf1f294e52193e90c05
EXTRA_OEMAKE += 'STRIP="echo"'
+inherit update-alternatives
+
+ALTERNATIVE_LINKS = "${base_sbindir}/hdparm"
+ALTERNATIVE_PRIORITY = "100"
+
do_install () {
install -d ${D}/${base_sbindir} ${D}/${mandir}/man8 ${D}/${bindir}
oe_runmake 'DESTDIR=${D}' 'sbindir=${base_sbindir}' install
- mv ${D}${base_sbindir}/hdparm ${D}${base_sbindir}/hdparm.${PN}
cp ${S}/wiper/wiper.sh ${D}/${bindir}
}
-
-pkg_postinst_${PN} () {
- update-alternatives --install ${base_sbindir}/hdparm hdparm hdparm.${PN} 100
-}
-
-pkg_prerm_${PN} () {
- update-alternatives --remove hdparm hdparm.${PN}
-}