aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/groff
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2011-09-03 20:51:02 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-09-05 17:53:02 +0100
commit9106e2922ba5972e3b87436372a12c2e04e9eb65 (patch)
tree0f45395a63a94d54fccc6afd1db5de6382217b8e /meta/recipes-extended/groff
parent0616557a8c29b42bae0ffd5fd665a046810047e4 (diff)
downloadopenembedded-core-9106e2922ba5972e3b87436372a12c2e04e9eb65.tar.gz
groff: Fix sstate relocation issue
[YOCTO #1439] This fixes a problem where the native groff has a path hard coded into it, therefor add a wrapper to set the command line with the correct paths for fonts and tmac directories. Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-extended/groff')
-rw-r--r--meta/recipes-extended/groff/groff_1.20.1.bb9
1 files changed, 8 insertions, 1 deletions
diff --git a/meta/recipes-extended/groff/groff_1.20.1.bb b/meta/recipes-extended/groff/groff_1.20.1.bb
index 7085911002..6cb72bf117 100644
--- a/meta/recipes-extended/groff/groff_1.20.1.bb
+++ b/meta/recipes-extended/groff/groff_1.20.1.bb
@@ -4,7 +4,7 @@ formatting commands and produces formatted output."
SECTION = "base"
HOMEPAGE = "ftp://ftp.gnu.org/gnu/groff/"
LICENSE = "GPLv2"
-PR = "r0"
+PR = "r1"
LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
@@ -34,4 +34,11 @@ do_configure_prepend() {
fi
}
+do_install_append_virtclass-native() {
+ create_cmdline_wrapper ${D}/${bindir}/groff \
+ -F${STAGING_DIR_NATIVE}${datadir_native}/groff/${PV}/font \
+ -M${STAGING_DIR_NATIVE}${datadir_native}/groff/${PV}/tmac
+}
+
+
BBCLASSEXTEND = "native"