aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/ghostscript
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2012-11-30 10:33:32 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-12-03 14:18:21 +0000
commit30a19b7c791abcbf09193c678866df66d470a6d9 (patch)
tree8f6607111822d1084e3eebc31bab0cd77052b6a2 /meta/recipes-extended/ghostscript
parentcb8fbc332f730cbb4d9c9866ee7b95d62245d121 (diff)
downloadopenembedded-core-30a19b7c791abcbf09193c678866df66d470a6d9.tar.gz
ghostscript: make ghostscript work with long building path
If TMPDIR has more than 256 chars, building ghostscript fails. This violates the 410 length limit of TMPDIR. This patch makes building ghostscript succeed by changing its MAX_TOKEN from 256 to 512. [YOCTO #2766] Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/ghostscript')
-rw-r--r--meta/recipes-extended/ghostscript/ghostscript/0001-make-ghostscript-work-with-long-building-directory.patch19
-rw-r--r--meta/recipes-extended/ghostscript/ghostscript_9.05.bb10
2 files changed, 23 insertions, 6 deletions
diff --git a/meta/recipes-extended/ghostscript/ghostscript/0001-make-ghostscript-work-with-long-building-directory.patch b/meta/recipes-extended/ghostscript/ghostscript/0001-make-ghostscript-work-with-long-building-directory.patch
new file mode 100644
index 0000000000..a4ce70a9ab
--- /dev/null
+++ b/meta/recipes-extended/ghostscript/ghostscript/0001-make-ghostscript-work-with-long-building-directory.patch
@@ -0,0 +1,19 @@
+Upstream-Status: Inappropriate [distribution]
+
+Make ghost script work with long building directory
+
+Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
+
+Index: base/genconf.c
+==============================================================
+--- a/base/genconf.c
++++ b/base/genconf.c
+@@ -682,7 +682,7 @@ read_dev(config_t * pconf, const char *arg)
+ string_item_t *item;
+ const char *in;
+
+-#define MAX_TOKEN 256
++#define MAX_TOKEN 512
+ char *token = malloc(MAX_TOKEN + 1);
+ char *category = malloc(MAX_TOKEN + 1);
+ int file_index;
diff --git a/meta/recipes-extended/ghostscript/ghostscript_9.05.bb b/meta/recipes-extended/ghostscript/ghostscript_9.05.bb
index 1fdcb997e7..2789897917 100644
--- a/meta/recipes-extended/ghostscript/ghostscript_9.05.bb
+++ b/meta/recipes-extended/ghostscript/ghostscript_9.05.bb
@@ -15,7 +15,7 @@ SECTION = "console/utils"
LICENSE = "GPLv3"
LIC_FILES_CHKSUM = "file://LICENSE;md5=c5326026692dbed183f0558f926580f8"
-PR = "r3"
+PR = "r4"
DEPENDS = "ghostscript-native tiff jpeg fontconfig cups"
DEPENDS_class-native = ""
@@ -30,7 +30,9 @@ SRC_URI = "${SRC_URI_BASE} \
file://ghostscript-9.05-NOT-check-endian.patch \
"
-SRC_URI_class-native = "${SRC_URI_BASE}"
+SRC_URI_class-native = "${SRC_URI_BASE} \
+ file://0001-make-ghostscript-work-with-long-building-directory.patch \
+ "
SRC_URI[md5sum] = "f7c6f0431ca8d44ee132a55d583212c1"
SRC_URI[sha256sum] = "593f77f7584704bdf9de41598a084a4208c3ad3b940a1de1faaf8f59a15cc207"
@@ -80,10 +82,6 @@ do_install_append () {
chown -R root:lp ${D}${sysconfdir}/cups
}
-python do_patch_class-native () {
- pass
-}
-
do_compile_class-native () {
mkdir -p obj
for i in genarch genconf mkromfs echogs gendev genht; do