aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/foomatic
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@windriver.com>2011-09-22 12:12:10 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-09-22 21:00:58 +0100
commitef7ad7a7c6b5f5a6c9d0d9e35e07b5a0dabe5be9 (patch)
treea749bb08d2b5d901617800730ac2140c16744734 /meta/recipes-extended/foomatic
parent24ae432b1a3906956381d83c1984687e45c5a1d1 (diff)
downloadopenembedded-core-ef7ad7a7c6b5f5a6c9d0d9e35e07b5a0dabe5be9.tar.gz
foomatic-filters: Disable filter checking
Disable a few checks, and hard code the values for a few other items to work around potential host contamination issues. We also default to the cups configuration for items. Signed-off-by: Mark Hatle <mark.hatle@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/foomatic')
-rw-r--r--meta/recipes-extended/foomatic/foomatic-filters_4.0.7.bb21
1 files changed, 15 insertions, 6 deletions
diff --git a/meta/recipes-extended/foomatic/foomatic-filters_4.0.7.bb b/meta/recipes-extended/foomatic/foomatic-filters_4.0.7.bb
index 9627187569..e3bcf782eb 100644
--- a/meta/recipes-extended/foomatic/foomatic-filters_4.0.7.bb
+++ b/meta/recipes-extended/foomatic/foomatic-filters_4.0.7.bb
@@ -10,7 +10,7 @@ format using a printer-specific, but spooler-independent PPD file. \
"
DEPENDS += "cups perl libxml2"
-PR = "r1"
+PR = "r2"
LICENSE = "GPLv2+"
LIC_FILES_CHKSUM = "file://${WORKDIR}/foomatic-filters-${PV}/COPYING;md5=393a5ca445f6965873eca0259a17f833"
@@ -20,11 +20,20 @@ SRC_URI = "http://www.openprinting.org/download/foomatic/foomatic-filters-${PV}.
SRC_URI[md5sum] = "20abd25c1c98b2dae68709062a132a7d"
SRC_URI[sha256sum] = "090313fae40b177f505d9c9b93d7a4d7188b6d5d18b6ae41ab24903ac983478d"
-do_install_append_linuxstdbase() {
- install -d ${D}${libdir}/cups/filter
- ln -sf ${bindir}/foomatic-rip ${D}${libdir}/cups/filter
+inherit autotools
+
+EXTRA_OECONF += "--disable-file-converter-check --with-file-converter=texttops"
+
+do_configure_prepend() {
+ export LIB_CUPS=${exec_prefix}/lib/cups # /usr/lib NOT libdir
+ export CUPS_BACKENDS=${exec_prefix}/lib/cups/backend # /usr/lib NOT libdir
+ export CUPS_FILTERS=${exec_prefix}/lib/cups/filter # /usr/lib NOT libdir
+ export CUPS_PPDS=${datadir}/cups/model
}
-FILES_${PN}_append_linuxstdbase += "${libdir}/cups/filter/foomatic-rip"
+do_install_append_linuxstdbase() {
+ install -d ${D}${exec_prefix}/lib/cups/filter
+ ln -sf ${bindir}/foomatic-rip ${D}${exec_prefix}/lib/cups/filter
+}
-inherit autotools
+FILES_${PN}_append_linuxstdbase += "${exec_prefix}/lib/cups/filter/foomatic-rip"