aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/findutils
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2012-07-26 16:29:45 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-08-15 14:18:39 +0100
commit071a959d430402a78ca5b392c8387489da042c08 (patch)
treeb4762af0b314116c0e522423fa559c2aa3d2d7fc /meta/recipes-extended/findutils
parent47620d768194fd69a75f4c19d77dcbdd22eadcb6 (diff)
downloadopenembedded-core-071a959d430402a78ca5b392c8387489da042c08.tar.gz
findutils: refactor common code to findutils.inc
Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-extended/findutils')
-rw-r--r--meta/recipes-extended/findutils/findutils.inc5
-rw-r--r--meta/recipes-extended/findutils/findutils_4.2.31.bb29
-rw-r--r--meta/recipes-extended/findutils/findutils_4.4.2.bb6
3 files changed, 10 insertions, 30 deletions
diff --git a/meta/recipes-extended/findutils/findutils.inc b/meta/recipes-extended/findutils/findutils.inc
index 64909a1f8c..1fa9b97d0e 100644
--- a/meta/recipes-extended/findutils/findutils.inc
+++ b/meta/recipes-extended/findutils/findutils.inc
@@ -6,9 +6,6 @@ HOMEPAGE = "http://www.gnu.org/software/findutils/"
BUGTRACKER = "http://savannah.gnu.org/bugs/?group=findutils"
SECTION = "console/utils"
-# GPLv2+ (<< 4.2.32), GPLv3+ (>= 4.2.32)
-LICENSE = "GPLv3+"
-LIC_FILES_CHKSUM = "file://COPYING;md5=f27defe1e96c2e1ecd4e0c9be8967949"
SRC_URI = "${GNU_MIRROR}/findutils/findutils-${PV}.tar.gz"
@@ -23,3 +20,5 @@ ALTERNATIVE_PRIORITY = "100"
# because it uses __mempcpy, there are other things (TBD:
# see diffutils.mk in buildroot)
EXTRA_OECONF_libc-uclibc = "--without-included-regex"
+
+BBCLASSEXTEND = "native"
diff --git a/meta/recipes-extended/findutils/findutils_4.2.31.bb b/meta/recipes-extended/findutils/findutils_4.2.31.bb
index 37da0ce340..38cdc219b9 100644
--- a/meta/recipes-extended/findutils/findutils_4.2.31.bb
+++ b/meta/recipes-extended/findutils/findutils_4.2.31.bb
@@ -1,33 +1,12 @@
-SUMMARY = "find, locate, and xargs binaries."
-DESCRIPTION = "The GNU Find Utilities are the basic directory searching utilities of the GNU operating system. \
-These programs are typically used in conjunction with other programs to provide modular and powerful directory \
-search and file locating capabilities to other commands."
-HOMEPAGE = "http://www.gnu.org/software/findutils/"
-BUGTRACKER = "http://savannah.gnu.org/bugs/?group=findutils"
-SECTION = "console/utils"
-
LICENSE = "GPLv2+"
LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
PR = "r3"
-SRC_URI = "${GNU_MIRROR}/findutils/findutils-${PV}.tar.gz \
- file://gnulib-extension.patch \
- file://findutils_fix_for_automake-1.12.patch \
+require findutils.inc
+
+SRC_URI += "file://gnulib-extension.patch \
+ file://findutils_fix_for_automake-1.12.patch \
"
SRC_URI[md5sum] = "a0e31a0f18a49709bf5a449867c8049a"
SRC_URI[sha256sum] = "e0d34b8faca0b3cca0703f6c6b498afbe72f0ba16c35980c10ec9ef7724d6204"
-
-inherit autotools gettext update-alternatives
-
-ALTERNATIVE_LINKS = "${bindir}/find ${bindir}/xargs"
-ALTERNATIVE_PRIORITY = "100"
-
-# diffutils assumes non-glibc compilation with uclibc and
-# this causes it to generate its own implementations of
-# standard functionality. regex.c actually breaks compilation
-# because it uses __mempcpy, there are other things (TBD:
-# see diffutils.mk in buildroot)
-EXTRA_OECONF_libc-uclibc = "--without-included-regex"
-
-BBCLASSEXTEND = "native"
diff --git a/meta/recipes-extended/findutils/findutils_4.4.2.bb b/meta/recipes-extended/findutils/findutils_4.4.2.bb
index 34e53d2eea..3f493007a5 100644
--- a/meta/recipes-extended/findutils/findutils_4.4.2.bb
+++ b/meta/recipes-extended/findutils/findutils_4.4.2.bb
@@ -1,5 +1,9 @@
require findutils.inc
+# GPLv2+ (<< 4.2.32), GPLv3+ (>= 4.2.32)
+LICENSE = "GPLv3+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=f27defe1e96c2e1ecd4e0c9be8967949"
+
PR = "r6"
SRC_URI += "file://01-27017.patch \
@@ -18,5 +22,3 @@ DEPENDS = "bison-native"
CACHED_CONFIGUREVARS += "${@base_contains('DISTRO_FEATURES', 'libc-posix-clang-wchar', 'gl_cv_func_wcwidth_works=yes', '', d)}"
EXTRA_OECONF += "ac_cv_path_SORT=${bindir}/sort"
-
-BBCLASSEXTEND = "native"