aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/cups
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2012-03-16 15:17:09 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-03-16 16:46:28 +0000
commitedb8eb566968d386f6995b95d54bc7c25a50b02a (patch)
treee5195733f185089090e3f7683e8c319d94614c9d /meta/recipes-extended/cups
parent93ba71e53d3295e35ef3a1c424d0a348a66c2f22 (diff)
downloadopenembedded-core-edb8eb566968d386f6995b95d54bc7c25a50b02a.tar.gz
cups: Ensure cups-config has correct target paths, not sysroot ones for cups_serverbin and cups_datadir variables
These are used by dependent packages to know where to install cups related pieces into therefore we need to remove the sysroot prefix from these. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/cups')
-rw-r--r--meta/recipes-extended/cups/cups14.inc5
-rw-r--r--meta/recipes-extended/cups/cups_1.4.6.bb2
2 files changed, 6 insertions, 1 deletions
diff --git a/meta/recipes-extended/cups/cups14.inc b/meta/recipes-extended/cups/cups14.inc
index 2bf3ecfd6f..7c1968220d 100644
--- a/meta/recipes-extended/cups/cups14.inc
+++ b/meta/recipes-extended/cups/cups14.inc
@@ -91,3 +91,8 @@ FILES_${PN} += "${datadir}/doc/cups/images \
${datadir}/doc/cups/*.css \
${datadir}/icons/ \
"
+
+SYSROOT_PREPROCESS_FUNCS += "cups_sysroot_preprocess"
+cups_sysroot_preprocess () {
+ sed -i ${SYSROOT_DESTDIR}${bindir_crossscripts}/cups-config -e 's:cups_datadir=.*:cups_datadir=${datadir}/cups:' -e 's:cups_serverbin=.*:cups_serverbin=${libdir}/cups:'
+}
diff --git a/meta/recipes-extended/cups/cups_1.4.6.bb b/meta/recipes-extended/cups/cups_1.4.6.bb
index 0dc2d4a26b..ec555d791d 100644
--- a/meta/recipes-extended/cups/cups_1.4.6.bb
+++ b/meta/recipes-extended/cups/cups_1.4.6.bb
@@ -1,6 +1,6 @@
require cups14.inc
-PR = "r2"
+PR = "r3"
DEPENDS += "libusb \
${@base_contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}"