aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/cpio
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@windriver.com>2012-11-15 15:26:09 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-12-06 12:30:31 +0000
commit487d58a98cd9fe4b368f0e7d119f8ff7ac852781 (patch)
tree9fd040fabd70a6520e614bba762490ed4831159f /meta/recipes-extended/cpio
parent268ede582e7b68854965b29a57e865b5fc7deb04 (diff)
downloadopenembedded-core-487d58a98cd9fe4b368f0e7d119f8ff7ac852781.tar.gz
cpio: Split RMT from cpio
After the recent change of the libexecdir definition, the update-alternatives for the libexec rmt broke. Fix this by moving rmt from libexec to /sbin. Also split the rmt app from cpio as it's likely not useful to many users. Signed-off-by: Mark Hatle <mark.hatle@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-extended/cpio')
-rw-r--r--meta/recipes-extended/cpio/cpio_2.11.bb2
-rw-r--r--meta/recipes-extended/cpio/cpio_2.8.bb2
-rw-r--r--meta/recipes-extended/cpio/cpio_v2.inc11
3 files changed, 11 insertions, 4 deletions
diff --git a/meta/recipes-extended/cpio/cpio_2.11.bb b/meta/recipes-extended/cpio/cpio_2.11.bb
index 9b37dcdeba..5f88b30f1e 100644
--- a/meta/recipes-extended/cpio/cpio_2.11.bb
+++ b/meta/recipes-extended/cpio/cpio_2.11.bb
@@ -3,7 +3,7 @@ include cpio_v2.inc
LICENSE = "GPLv3"
LIC_FILES_CHKSUM = "file://COPYING;md5=f27defe1e96c2e1ecd4e0c9be8967949"
-PR = "r3"
+PR = "r4"
SRC_URI += "file://remove-gets.patch \
"
diff --git a/meta/recipes-extended/cpio/cpio_2.8.bb b/meta/recipes-extended/cpio/cpio_2.8.bb
index cabc1cd605..b6da207b92 100644
--- a/meta/recipes-extended/cpio/cpio_2.8.bb
+++ b/meta/recipes-extended/cpio/cpio_2.8.bb
@@ -3,7 +3,7 @@ require cpio_v2.inc
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=b7f772ea3a2489231cb4872656cac34b"
-PR = "r2"
+PR = "r3"
SRC_URI += "file://m4extensions.patch \
file://avoid_heap_overflow.patch \
diff --git a/meta/recipes-extended/cpio/cpio_v2.inc b/meta/recipes-extended/cpio/cpio_v2.inc
index 3b3402b536..30446b0ced 100644
--- a/meta/recipes-extended/cpio/cpio_v2.inc
+++ b/meta/recipes-extended/cpio/cpio_v2.inc
@@ -14,6 +14,8 @@ inherit autotools gettext
S = "${WORKDIR}/cpio-${PV}"
+EXTRA_OECONF += "DEFAULT_RMT_DIR=${base_sbindir}"
+
do_install () {
autotools_do_install
install -d ${D}${base_bindir}/
@@ -21,13 +23,18 @@ do_install () {
rmdir ${D}${bindir}/
}
+PACKAGES =+ "${PN}-rmt"
+
+FILES_${PN}-rmt = "${base_sbindir}/rmt*"
+
inherit update-alternatives
ALTERNATIVE_PRIORITY = "100"
-ALTERNATIVE_${PN} = "cpio rmt"
+ALTERNATIVE_${PN} = "cpio"
+ALTERNATIVE_${PN}-rmt = "rmt"
ALTERNATIVE_LINK_NAME[cpio] = "${base_bindir}/cpio"
ALTERNATIVE_PRIORITY[rmt] = "50"
-ALTERNATIVE_LINK_NAME[rmt] = "${libexecdir}/rmt"
+ALTERNATIVE_LINK_NAME[rmt] = "${base_sbindir}/rmt"