aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/bzip2
diff options
context:
space:
mode:
authorBjörn Stenberg <bjst@enea.com>2013-06-26 11:43:59 +0200
committerSaul Wold <sgw@linux.intel.com>2013-06-27 09:55:57 -0700
commitf02258b304dc4544567601a1502080f3581c00fa (patch)
tree2e75464452a155668bb5925c9865d57b591297db /meta/recipes-extended/bzip2
parent5f2dd65e758ead8177a1cdda047bdb105b96e208 (diff)
downloadopenembedded-core-f02258b304dc4544567601a1502080f3581c00fa.tar.gz
bzip2: Add ptest
The existing bzip2 tests in the upstream Makefile are copied to Makefile.am (yocto's) and modified to adopt to the ptest format. Signed-off-by: Björn Stenberg <bjst@enea.com> Signed-off-by: Anders Roxell <anders.roxell@enea.com> Signed-off-by: Sona Sarmadi <sona.sarmadi@enea.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-extended/bzip2')
-rw-r--r--meta/recipes-extended/bzip2/bzip2-1.0.6/Makefile.am30
-rw-r--r--meta/recipes-extended/bzip2/bzip2-1.0.6/run-ptest2
-rw-r--r--meta/recipes-extended/bzip2/bzip2_1.0.6.bb7
3 files changed, 38 insertions, 1 deletions
diff --git a/meta/recipes-extended/bzip2/bzip2-1.0.6/Makefile.am b/meta/recipes-extended/bzip2/bzip2-1.0.6/Makefile.am
index 070d57b243..1d163b6c98 100644
--- a/meta/recipes-extended/bzip2/bzip2-1.0.6/Makefile.am
+++ b/meta/recipes-extended/bzip2/bzip2-1.0.6/Makefile.am
@@ -26,6 +26,36 @@ bin_SCRIPTS = bzgrep bzmore bzdiff
man_MANS = bzip2.1 bzgrep.1 bzmore.1 bzdiff.1
EXTRA_DIST = $(man_MANS)
+runtest:
+ ./bzip2 -1 < sample1.ref > sample1.rb2
+ ./bzip2 -2 < sample2.ref > sample2.rb2
+ ./bzip2 -3 < sample3.ref > sample3.rb2
+ ./bzip2 -d < sample1.bz2 > sample1.tst
+ ./bzip2 -d < sample2.bz2 > sample2.tst
+ ./bzip2 -ds < sample3.bz2 > sample3.tst
+ @if cmp sample1.bz2 sample1.rb2; then echo "PASS: sample1 compress";\
+ else echo "FAIL: sample1 compress"; fi
+ @if cmp sample2.bz2 sample2.rb2; then echo "PASS: sample2 compress";\
+ else echo "FAIL: sample2 compress"; fi
+ @if cmp sample3.bz2 sample3.rb2; then echo "PASS: sample3 compress";\
+ else echo "FAIL: sample3 compress"; fi
+ @if cmp sample1.tst sample1.ref; then echo "PASS: sample1 decompress";\
+ else echo "FAIL: sample1 decompress"; fi
+ @if cmp sample2.tst sample2.ref; then echo "PASS: sample2 decompress";\
+ else echo "FAIL: sample2 decompress"; fi
+ @if cmp sample3.tst sample3.ref; then echo "PASS: sample3 decompress";\
+ else echo "FAIL: sample3 decompress"; fi
+
+install-ptest:
+ cp $(srcdir)/Makefile $(DESTDIR)/
+ cp $(srcdir)/sample1.ref $(DESTDIR)/
+ cp $(srcdir)/sample2.ref $(DESTDIR)/
+ cp $(srcdir)/sample3.ref $(DESTDIR)/
+ cp $(srcdir)/sample1.bz2 $(DESTDIR)/
+ cp $(srcdir)/sample2.bz2 $(DESTDIR)/
+ cp $(srcdir)/sample3.bz2 $(DESTDIR)/
+ ln -s $(bindir)/bzip2 $(DESTDIR)/bzip2
+
install-exec-hook:
ln -s $(bindir)/bzip2$(EXEEXT) $(DESTDIR)$(bindir)/bunzip2$(EXEEXT)
ln -s $(bindir)/bzip2$(EXEEXT) $(DESTDIR)$(bindir)/bzcat$(EXEEXT)
diff --git a/meta/recipes-extended/bzip2/bzip2-1.0.6/run-ptest b/meta/recipes-extended/bzip2/bzip2-1.0.6/run-ptest
new file mode 100644
index 0000000000..3b20fce1ee
--- /dev/null
+++ b/meta/recipes-extended/bzip2/bzip2-1.0.6/run-ptest
@@ -0,0 +1,2 @@
+#!/bin/sh
+make -k runtest
diff --git a/meta/recipes-extended/bzip2/bzip2_1.0.6.bb b/meta/recipes-extended/bzip2/bzip2_1.0.6.bb
index 6e160cd3e0..4189f78fdf 100644
--- a/meta/recipes-extended/bzip2/bzip2_1.0.6.bb
+++ b/meta/recipes-extended/bzip2/bzip2_1.0.6.bb
@@ -10,6 +10,7 @@ PR = "r5"
SRC_URI = "http://www.bzip.org/${PV}/${BPN}-${PV}.tar.gz \
file://configure.ac \
+ file://run-ptest \
file://Makefile.am"
SRC_URI[md5sum] = "00b516f4704d4a7cb50a1d97e6e8e15b"
@@ -19,7 +20,7 @@ PACKAGES =+ "libbz2 libbz2-dev libbz2-staticdev"
CFLAGS_append = " -fPIC -fpic -Winline -fno-strength-reduce -D_FILE_OFFSET_BITS=64"
-inherit autotools update-alternatives
+inherit autotools update-alternatives ptest
ALTERNATIVE_PRIORITY = "100"
ALTERNATIVE_${PN} = "bunzip2 bzcat"
@@ -32,6 +33,10 @@ do_configure_prepend () {
cp ${STAGING_DATADIR_NATIVE}/automake*/install-sh ${S}/
}
+do_install_ptest () {
+ sed -i -e "s|^Makefile:|_Makefile:|" ${D}${PTEST_PATH}/Makefile
+}
+
FILES_libbz2 = "${libdir}/lib*${SOLIBS}"
FILES_libbz2-dev = "${includedir} ${libdir}/lib*${SOLIBSDEV}"