aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/bzip2/bzip2_1.0.6.bb
diff options
context:
space:
mode:
authorBjörn Stenberg <bjst@enea.com>2013-06-26 11:43:59 +0200
committerSaul Wold <sgw@linux.intel.com>2013-06-27 09:55:57 -0700
commitf02258b304dc4544567601a1502080f3581c00fa (patch)
tree2e75464452a155668bb5925c9865d57b591297db /meta/recipes-extended/bzip2/bzip2_1.0.6.bb
parent5f2dd65e758ead8177a1cdda047bdb105b96e208 (diff)
downloadopenembedded-core-f02258b304dc4544567601a1502080f3581c00fa.tar.gz
bzip2: Add ptest
The existing bzip2 tests in the upstream Makefile are copied to Makefile.am (yocto's) and modified to adopt to the ptest format. Signed-off-by: Björn Stenberg <bjst@enea.com> Signed-off-by: Anders Roxell <anders.roxell@enea.com> Signed-off-by: Sona Sarmadi <sona.sarmadi@enea.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-extended/bzip2/bzip2_1.0.6.bb')
-rw-r--r--meta/recipes-extended/bzip2/bzip2_1.0.6.bb7
1 files changed, 6 insertions, 1 deletions
diff --git a/meta/recipes-extended/bzip2/bzip2_1.0.6.bb b/meta/recipes-extended/bzip2/bzip2_1.0.6.bb
index 6e160cd3e0..4189f78fdf 100644
--- a/meta/recipes-extended/bzip2/bzip2_1.0.6.bb
+++ b/meta/recipes-extended/bzip2/bzip2_1.0.6.bb
@@ -10,6 +10,7 @@ PR = "r5"
SRC_URI = "http://www.bzip.org/${PV}/${BPN}-${PV}.tar.gz \
file://configure.ac \
+ file://run-ptest \
file://Makefile.am"
SRC_URI[md5sum] = "00b516f4704d4a7cb50a1d97e6e8e15b"
@@ -19,7 +20,7 @@ PACKAGES =+ "libbz2 libbz2-dev libbz2-staticdev"
CFLAGS_append = " -fPIC -fpic -Winline -fno-strength-reduce -D_FILE_OFFSET_BITS=64"
-inherit autotools update-alternatives
+inherit autotools update-alternatives ptest
ALTERNATIVE_PRIORITY = "100"
ALTERNATIVE_${PN} = "bunzip2 bzcat"
@@ -32,6 +33,10 @@ do_configure_prepend () {
cp ${STAGING_DATADIR_NATIVE}/automake*/install-sh ${S}/
}
+do_install_ptest () {
+ sed -i -e "s|^Makefile:|_Makefile:|" ${D}${PTEST_PATH}/Makefile
+}
+
FILES_libbz2 = "${libdir}/lib*${SOLIBS}"
FILES_libbz2-dev = "${includedir} ${libdir}/lib*${SOLIBSDEV}"