summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/bash
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2014-03-03 18:55:58 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-03-05 15:24:05 +0000
commit3c234df240a11903ef3588a2c078dcbce4ca1719 (patch)
treea924b6b1ad8dec3ee88e1fef7a16ec0bda045795 /meta/recipes-extended/bash
parent31eb09a888729fcfd17d02f2a47375e10e87f79a (diff)
downloadopenembedded-core-3c234df240a11903ef3588a2c078dcbce4ca1719.tar.gz
bash: update build-tests.patch
Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/bash')
-rw-r--r--meta/recipes-extended/bash/bash/build-tests.patch (renamed from meta/recipes-extended/bash/bash-4.2/build-tests.patch)33
1 files changed, 20 insertions, 13 deletions
diff --git a/meta/recipes-extended/bash/bash-4.2/build-tests.patch b/meta/recipes-extended/bash/bash/build-tests.patch
index 036088116d..73a81b60da 100644
--- a/meta/recipes-extended/bash/bash-4.2/build-tests.patch
+++ b/meta/recipes-extended/bash/bash/build-tests.patch
@@ -1,29 +1,33 @@
Add 'ptest' target to Makefile, to run tests without checking dependencies.
-Signed-off-by: Anders Roxell <anders.roxell@enea.com>
Upstream-Status: Pending
+Signed-off-by: Anders Roxell <anders.roxell@enea.com>
+Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
---
-diff -uNr a/Makefile.in b/Makefile.in
---- a/Makefile.in 2012-11-06 08:40:07.552403063 +0100
-+++ b/Makefile.in 2012-11-06 11:13:36.958297555 +0100
-@@ -827,20 +827,34 @@
+ Makefile.in | 24 +++++++++++++++++++-----
+ 1 file changed, 19 insertions(+), 5 deletions(-)
+
+diff --git a/Makefile.in b/Makefile.in
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -848,20 +848,34 @@ maybe-clean:
fi
recho$(EXEEXT): $(SUPPORT_SRC)recho.c
-- @$(CC_FOR_BUILD) $(CCFLAGS_FOR_BUILD) -o $@ $(SUPPORT_SRC)recho.c ${LIBS_FOR_BUILD}
-+ @$(CC) $(CCFLAGS) -o $@ $<
+- @$(CC_FOR_BUILD) $(CCFLAGS_FOR_BUILD) ${LDFLAGS_FOR_BUILD} -o $@ $(SUPPORT_SRC)recho.c ${LIBS_FOR_BUILD}
++ @$(CC) $(CCFLAGS) ${LDFLAGS} -o $@ $<
zecho$(EXEEXT): $(SUPPORT_SRC)zecho.c
-- @$(CC_FOR_BUILD) $(CCFLAGS_FOR_BUILD) -o $@ $(SUPPORT_SRC)zecho.c ${LIBS_FOR_BUILD}
-+ @$(CC) $(CCFLAGS) -o $@ $<
+- @$(CC_FOR_BUILD) $(CCFLAGS_FOR_BUILD) ${LDFLAGS_FOR_BUILD} -o $@ $(SUPPORT_SRC)zecho.c ${LIBS_FOR_BUILD}
++ @$(CC) $(CCFLAGS) ${LDFLAGS} -o $@ $<
printenv$(EXEEXT): $(SUPPORT_SRC)printenv.c
-- @$(CC_FOR_BUILD) $(CCFLAGS_FOR_BUILD) -o $@ $(SUPPORT_SRC)printenv.c ${LIBS_FOR_BUILD}
-+ @$(CC) $(CCFLAGS) -o $@ $<
+- @$(CC_FOR_BUILD) $(CCFLAGS_FOR_BUILD) ${LDFLAGS_FOR_BUILD} -o $@ $(SUPPORT_SRC)printenv.c ${LIBS_FOR_BUILD}
++ @$(CC) $(CCFLAGS) ${LDFLAGS} -o $@ $<
xcase$(EXEEXT): $(SUPPORT_SRC)xcase.c
-- @$(CC_FOR_BUILD) $(CCFLAGS_FOR_BUILD) -o $@ $(SUPPORT_SRC)xcase.c ${LIBS_FOR_BUILD}
-+ @$(CC) $(CCFLAGS) -o $@ $<
+- @$(CC_FOR_BUILD) $(CCFLAGS_FOR_BUILD) ${LDFLAGS_FOR_BUILD} -o $@ $(SUPPORT_SRC)xcase.c ${LIBS_FOR_BUILD}
++ @$(CC) $(CCFLAGS) ${LDFLAGS} -o $@ $<
-test tests check: force $(Program) $(TESTS_SUPPORT)
+test tests check:
@@ -46,3 +50,6 @@ diff -uNr a/Makefile.in b/Makefile.in
@( cd $(srcdir)/tests && \
PATH=$(BUILD_DIR)/tests:$$PATH THIS_SH=$(THIS_SH) $(SHELL) ${TESTSCRIPT} )
+--
+1.8.1.2
+