summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/bash
diff options
context:
space:
mode:
authorJuro Bystricky <juro.bystricky@intel.com>2017-08-28 13:28:20 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-08-30 11:20:49 +0100
commit26a29d85648b68bb1d2badd59de76f850054e059 (patch)
tree0a6e5743dcaf273c2563734e22fd9263f4765dc4 /meta/recipes-extended/bash
parente395bc4ab6c4a819958a761ee24de96f31294139 (diff)
downloadopenembedded-core-26a29d85648b68bb1d2badd59de76f850054e059.tar.gz
bash.inc: improve reproducibility
Remove all host build references from the following bash packages: bash-ptest, bash-bashbug, bash-dev, bash-loadable. [YOCTO #11918] Signed-off-by: Juro Bystricky <juro.bystricky@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/bash')
-rw-r--r--meta/recipes-extended/bash/bash.inc22
1 files changed, 19 insertions, 3 deletions
diff --git a/meta/recipes-extended/bash/bash.inc b/meta/recipes-extended/bash/bash.inc
index 92916d9a6a..f6cb7e4047 100644
--- a/meta/recipes-extended/bash/bash.inc
+++ b/meta/recipes-extended/bash/bash.inc
@@ -48,16 +48,32 @@ do_install_append () {
fi
}
do_install_append_class-target () {
- # Clean host path in bashbug
+ # Clean buildhost references in bashbug
sed -i -e "s,--sysroot=${STAGING_DIR_TARGET},,g" \
- -e "s,-I${WORKDIR}/\S* ,,g" ${D}${bindir}/bashbug
+ -e "s,-I${WORKDIR}/\S* ,,g" \
+ -e 's|${DEBUG_PREFIX_MAP}||g' \
+ ${D}${bindir}/bashbug
+
+ # Clean buildhost references in bash.pc
+ sed -i -e "s,--sysroot=${STAGING_DIR_TARGET},,g" \
+ ${D}${libdir}/pkgconfig/bash.pc
+
+ # Clean buildhost references in Makefile.inc
+ sed -i -e "s,--sysroot=${STAGING_DIR_TARGET},,g" \
+ -e 's|${DEBUG_PREFIX_MAP}||g' \
+ -e 's:${HOSTTOOLS_DIR}/::g' \
+ -e 's:${BASE_WORKDIR}/${MULTIMACH_TARGET_SYS}::g' \
+ ${D}${libdir}/bash/Makefile.inc
}
do_install_ptest () {
make INSTALL_TEST_DIR=${D}${PTEST_PATH}/tests install-test
cp ${B}/Makefile ${D}${PTEST_PATH}
sed -i -e 's/^Makefile/_Makefile/' -e "s,--sysroot=${STAGING_DIR_TARGET},,g" \
- -e "s,${S},,g" -e "s,${B},,g" -e "s,${STAGING_DIR_NATIVE},,g" ${D}${PTEST_PATH}/Makefile
+ -e 's|${DEBUG_PREFIX_MAP}||g' \
+ -e "s,${S},,g" -e "s,${B},,g" -e "s,${STAGING_DIR_NATIVE},,g" \
+ -e 's:${HOSTTOOLS_DIR}/::g' \
+ ${D}${PTEST_PATH}/Makefile
}
pkg_postinst_${PN} () {