aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/bash
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2011-11-02 11:41:05 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-11-04 17:04:06 +0000
commit08b78066bd5a9ff2819a42eb4263ee0a78cddb97 (patch)
tree4c9d666f0f17e157e5a19a7d648a7661a6c871a5 /meta/recipes-extended/bash
parente3c003282afb93ec52882496400b042620ab00ef (diff)
downloadopenembedded-core-08b78066bd5a9ff2819a42eb4263ee0a78cddb97.tar.gz
bash: Ensure we fully reautoconf the recipes so site data is used
This ensures bug 487 (missing job control functionality) really gets fixed. [YOCTO #487] Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/bash')
-rw-r--r--meta/recipes-extended/bash/bash.inc9
-rw-r--r--meta/recipes-extended/bash/bash_3.2.48.bb11
-rw-r--r--meta/recipes-extended/bash/bash_4.2.bb2
3 files changed, 14 insertions, 8 deletions
diff --git a/meta/recipes-extended/bash/bash.inc b/meta/recipes-extended/bash/bash.inc
index d55e517de1..876be1e42d 100644
--- a/meta/recipes-extended/bash/bash.inc
+++ b/meta/recipes-extended/bash/bash.inc
@@ -22,9 +22,12 @@ ALTERNATIVE_PATH = "${base_bindir}/bash"
ALTERNATIVE_LINK = "${base_bindir}/sh"
ALTERNATIVE_PRIORITY = "100"
-do_configure () {
- gnu-configize
- oe_runconf
+export AUTOHEADER = "true"
+
+do_configure_prepend () {
+ if [ ! -e acinclude.m4 ]; then
+ cat aclocal.m4 > acinclude.m4
+ fi
}
pkg_postinst_${PN} () {
diff --git a/meta/recipes-extended/bash/bash_3.2.48.bb b/meta/recipes-extended/bash/bash_3.2.48.bb
index 1520c4e6ba..f2ba5721c6 100644
--- a/meta/recipes-extended/bash/bash_3.2.48.bb
+++ b/meta/recipes-extended/bash/bash_3.2.48.bb
@@ -6,7 +6,7 @@ LICENSE = "GPLv2+"
LIC_FILES_CHKSUM = "file://COPYING;md5=fd5d9bcabd8ed5a54a01ce8d183d592a"
DEPENDS = "ncurses"
-PR = "r7"
+PR = "r8"
SRC_URI = "${GNU_MIRROR}/bash/bash-${PV}.tar.gz \
${GNU_MIRROR}/bash/bash-3.2-patches/bash32-049;apply=yes;striplevel=0 \
@@ -23,9 +23,12 @@ sbindir = "/sbin"
EXTRA_OECONF = "--with-ncurses"
export CC_FOR_BUILD = "${BUILD_CC}"
-do_configure () {
- gnu-configize
- oe_runconf
+export AUTOHEADER = "true"
+
+do_configure_prepend () {
+ if [ ! -e acinclude.m4 ]; then
+ cat aclocal.m4 > acinclude.m4
+ fi
}
pkg_postinst_${PN} () {
diff --git a/meta/recipes-extended/bash/bash_4.2.bb b/meta/recipes-extended/bash/bash_4.2.bb
index a0f5e4ef96..80709183cd 100644
--- a/meta/recipes-extended/bash/bash_4.2.bb
+++ b/meta/recipes-extended/bash/bash_4.2.bb
@@ -1,6 +1,6 @@
require bash.inc
-PR = "r0"
+PR = "r1"
SRC_URI = "${GNU_MIRROR}/bash/${BPN}-${PV}.tar.gz;name=tarball \
${GNU_MIRROR}/bash/bash-4.2-patches/bash42-001;apply=yes;striplevel=0;name=patch001 \