aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/bash/bash.inc
diff options
context:
space:
mode:
authorBjörn Stenberg <bjst@enea.com>2012-12-19 17:18:31 +0100
committerSaul Wold <sgw@linux.intel.com>2012-12-25 14:00:20 -0800
commit71e07ce8d1e4c2a50e937f0c819f025afd4677cb (patch)
tree6a5799932f89aa6f37eff8ccc9188ec7feafae7d /meta/recipes-extended/bash/bash.inc
parent280e79adea4536b264a526072406d605d0822e7d (diff)
downloadopenembedded-core-71e07ce8d1e4c2a50e937f0c819f025afd4677cb.tar.gz
Add ptest for bash.
Signed-off-by: Björn Stenberg <bjst@enea.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-extended/bash/bash.inc')
-rw-r--r--meta/recipes-extended/bash/bash.inc16
1 files changed, 15 insertions, 1 deletions
diff --git a/meta/recipes-extended/bash/bash.inc b/meta/recipes-extended/bash/bash.inc
index f1de931e82..20a23f030f 100644
--- a/meta/recipes-extended/bash/bash.inc
+++ b/meta/recipes-extended/bash/bash.inc
@@ -4,7 +4,7 @@ SECTION = "base/shell"
DEPENDS = "ncurses bison-native"
-inherit autotools gettext update-alternatives
+inherit autotools gettext update-alternatives ptest
PARALLEL_MAKE = ""
@@ -17,18 +17,32 @@ ALTERNATIVE_PRIORITY = "100"
export AUTOHEADER = "true"
+RDEPENDS_${PN}-ptest += "make"
+
do_configure_prepend () {
if [ ! -e acinclude.m4 ]; then
cat aclocal.m4 > acinclude.m4
fi
}
+do_compile_append () {
+ if [ "${PN}" = "${BPN}" -a ${PTEST_ENABLED} = "1" ]; then
+ oe_runmake buildtest
+ fi
+}
+
do_install_append () {
# Move /usr/bin/bash to /bin/bash, if need
if [ "${base_bindir}" != "${bindir}" ]; then
mkdir -p ${D}${base_bindir}
mv ${D}${bindir}/bash ${D}${base_bindir}
fi
+
+ if [ "${PN}" = "${BPN}" -a ${PTEST_ENABLED} = "1" ]; then
+ ptest_do_install
+ make INSTALL_TEST_DIR=${D}${PTEST_PATH}/tests install-test
+ cp ${B}/Makefile ${D}${PTEST_PATH}
+ fi
}
pkg_postinst_${PN} () {