aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/augeas/augeas
diff options
context:
space:
mode:
authorConstantin Musca <constantinx.musca@intel.com>2013-02-18 14:05:09 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-02-22 05:52:27 -0800
commita711a8617c39b06c9a494d0ceae9f96f65b024f9 (patch)
treece6ddb2fcdfe2972d51f491f1a0c07f23c79df27 /meta/recipes-extended/augeas/augeas
parent4e7b91b5a2613b957b08aefbee1aac28fdd19598 (diff)
downloadopenembedded-core-a711a8617c39b06c9a494d0ceae9f96f65b024f9.tar.gz
augeas: upgrade to 1.0.0
0001-Add-missing-argument-to-escape.patch: removed - included in the new version remove-gets.patch: not needed anymore add-missing-argz-conditional.patch: added - the Makefiles assume that the argz conditional is present in configure.ac Signed-off-by: Constantin Musca <constantinx.musca@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-extended/augeas/augeas')
-rw-r--r--meta/recipes-extended/augeas/augeas/0001-Add-missing-argument-to-escape.patch29
-rw-r--r--meta/recipes-extended/augeas/augeas/add-missing-argz-conditional.patch20
-rw-r--r--meta/recipes-extended/augeas/augeas/remove-gets.patch20
3 files changed, 20 insertions, 49 deletions
diff --git a/meta/recipes-extended/augeas/augeas/0001-Add-missing-argument-to-escape.patch b/meta/recipes-extended/augeas/augeas/0001-Add-missing-argument-to-escape.patch
deleted file mode 100644
index 3d0d0e3726..0000000000
--- a/meta/recipes-extended/augeas/augeas/0001-Add-missing-argument-to-escape.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-Upstream-Status: Backport
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
-
-From 021ea39f8e400225e2d01b4c62eb9d56404f2ecd Mon Sep 17 00:00:00 2001
-From: Michael Chapman <mike@very.puzzling.org>
-Date: Fri, 16 Dec 2011 21:30:07 +1100
-Subject: [PATCH] Add missing argument to escape()
-
-Fixes ticket #242.
----
- src/regexp.c | 2 +-
- 1 files changed, 1 insertions(+), 1 deletions(-)
-
-diff --git a/src/regexp.c b/src/regexp.c
-index cf0ea5d..811087d 100644
---- a/src/regexp.c
-+++ b/src/regexp.c
-@@ -50,7 +50,7 @@ char *regexp_escape(const struct regexp *r) {
- ret = fa_restrict_alphabet(r->pattern->str, strlen(r->pattern->str),
- &nre, &nre_len, 2, 1);
- if (ret == 0) {
-- pat = escape(nre, nre_len);
-+ pat = escape(nre, nre_len, RX_ESCAPES);
- free(nre);
- }
- #endif
---
-1.7.5.4
-
diff --git a/meta/recipes-extended/augeas/augeas/add-missing-argz-conditional.patch b/meta/recipes-extended/augeas/augeas/add-missing-argz-conditional.patch
new file mode 100644
index 0000000000..abbdbaa63b
--- /dev/null
+++ b/meta/recipes-extended/augeas/augeas/add-missing-argz-conditional.patch
@@ -0,0 +1,20 @@
+Add missing GL_GENERATE_ARGZ_H conditional
+
+- GL_GENERATE_ARGZ_H is used in gnulib/lib/Makefile.am
+
+Upstream-Status: Pending
+Signed-off-by: Constantin Musca <constantinx.musca@intel.com>
+
+Index: augeas-1.0.0/configure.ac
+===================================================================
+--- augeas-1.0.0.orig/configure.ac
++++ augeas-1.0.0/configure.ac
+@@ -55,6 +55,8 @@ AC_ARG_WITH([failmalloc],
+
+ AM_CONDITIONAL([WITH_FAILMALLOC], [test x$with_failmalloc != xno])
+
++AM_CONDITIONAL([GL_GENERATE_ARGZ_H], [test -n "$ARGZ_H"])
++
+ dnl --enable-debug=(yes|no)
+ AC_ARG_ENABLE([debug],
+ [AC_HELP_STRING([--enable-debug=no/yes],
diff --git a/meta/recipes-extended/augeas/augeas/remove-gets.patch b/meta/recipes-extended/augeas/augeas/remove-gets.patch
deleted file mode 100644
index bd6e92cc66..0000000000
--- a/meta/recipes-extended/augeas/augeas/remove-gets.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-eglibc 2.16 has remove gets so check for it to be there before using it
-
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
-
-Upstream-Status: Pending
-Index: augeas-0.10.0/gnulib/lib/stdio.in.h
-===================================================================
---- augeas-0.10.0.orig/gnulib/lib/stdio.in.h 2011-03-03 17:07:59.000000000 -0800
-+++ augeas-0.10.0/gnulib/lib/stdio.in.h 2012-07-03 19:46:42.871894833 -0700
-@@ -161,8 +161,10 @@
- /* It is very rare that the developer ever has full control of stdin,
- so any use of gets warrants an unconditional warning. Assume it is
- always declared, since it is required by C89. */
-+#if defined gets
- #undef gets
- _GL_WARN_ON_USE (gets, "gets is a security hole - use fgets instead");
-+#endif
-
- #if @GNULIB_FOPEN@
- # if @REPLACE_FOPEN@