summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorWenzong Fan <wenzong.fan@windriver.com>2017-10-11 02:07:03 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-11-05 13:44:56 +0000
commitced5618e7b3459fdd96f448ccdb55b5ced6d8214 (patch)
treed1e116d6c01eaaa4d0f365540d39e9a5751f9418 /meta/recipes-devtools
parentba6e739ca9099a6d3603e197474e16c75013106b (diff)
downloadopenembedded-core-ced5618e7b3459fdd96f448ccdb55b5ced6d8214.tar.gz
tcl: remove host path from tclConfig.sh
The tclConfig.sh is also used by other packages (such as expect) for cross-compiling, the host path from it can't be removed directly in the do_install step. With PACKAGE_PREPROCESS_FUNCS to remove host path and avoid the crossscripts installed to target. Signed-off-by: Wenzong Fan <wenzong.fan@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/tcltk/tcl_8.6.7.bb13
1 files changed, 13 insertions, 0 deletions
diff --git a/meta/recipes-devtools/tcltk/tcl_8.6.7.bb b/meta/recipes-devtools/tcltk/tcl_8.6.7.bb
index d00d2dc62b..dac73be6e7 100644
--- a/meta/recipes-devtools/tcltk/tcl_8.6.7.bb
+++ b/meta/recipes-devtools/tcltk/tcl_8.6.7.bb
@@ -86,3 +86,16 @@ BINCONFIG_GLOB = "*Config.sh"
# Fix the path in sstate
SSTATE_SCAN_FILES += "*Config.sh"
+
+# Cleanup host path from ${libdir}/tclConfig.sh and remove the
+# ${bindir_crossscripts}/tclConfig.sh from target
+PACKAGE_PREPROCESS_FUNCS += "tcl_package_preprocess"
+tcl_package_preprocess() {
+ sed -i -e "s;${DEBUG_PREFIX_MAP};;g" \
+ -e "s;-L${STAGING_LIBDIR};-L${libdir};g" \
+ -e "s;${STAGING_INCDIR};${includedir};g" \
+ -e "s;--sysroot=${RECIPE_SYSROOT};;g" \
+ ${PKGD}${libdir}/tclConfig.sh
+
+ rm -f ${PKGD}${bindir_crossscripts}/tclConfig.sh
+}