summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2018-10-15 19:13:02 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-10-15 23:19:37 +0100
commitb4ea23adf58d664f3cc5abe6d04b507fc000426e (patch)
tree3a79ce14c7af9ba7b089abc3bfc10a9debe51020 /meta/recipes-devtools
parentfe3727af217dce4488f1fc6aab3f66232cf11fea (diff)
downloadopenembedded-core-b4ea23adf58d664f3cc5abe6d04b507fc000426e.tar.gz
python: remove the PN package entirely
Nothing should be in this package, so remove it entirely to be sure nothing does end up in there. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/python/python3_3.5.6.bb4
-rw-r--r--meta/recipes-devtools/python/python_2.7.15.bb3
2 files changed, 3 insertions, 4 deletions
diff --git a/meta/recipes-devtools/python/python3_3.5.6.bb b/meta/recipes-devtools/python/python3_3.5.6.bb
index 72478f8663..2a4547694a 100644
--- a/meta/recipes-devtools/python/python3_3.5.6.bb
+++ b/meta/recipes-devtools/python/python3_3.5.6.bb
@@ -215,6 +215,8 @@ py_package_preprocess () {
mv ${PKGD}/${bindir}/python${PYTHON_BINABI}-config ${PKGD}/${bindir}/python${PYTHON_BINABI}-config-${MULTILIB_SUFFIX}
}
+PACKAGES_remove = "${PN}"
+
# manual dependency additions
RPROVIDES_${PN}-modules = "${PN}"
RRECOMMENDS_${PN}-core_append_class-nativesdk = " nativesdk-python3-modules"
@@ -249,8 +251,6 @@ RDEPENDS_${PN}-dev = ""
BBCLASSEXTEND = "nativesdk"
-RPROVIDES_${PN} += "${PN}-modules"
-
# We want bytecode precompiled .py files (.pyc's) by default
# but the user may set it on their own conf
INCLUDE_PYCS ?= "1"
diff --git a/meta/recipes-devtools/python/python_2.7.15.bb b/meta/recipes-devtools/python/python_2.7.15.bb
index d78400b6e6..b402ad6f1e 100644
--- a/meta/recipes-devtools/python/python_2.7.15.bb
+++ b/meta/recipes-devtools/python/python_2.7.15.bb
@@ -152,6 +152,7 @@ py_package_preprocess () {
(cd ${PKGD}; python -m py_compile ./${libdir}/python${PYTHON_MAJMIN}/_sysconfigdata.py)
}
+PACKAGES_remove = "${PN}"
# manual dependency additions
RPROVIDES_${PN}-core = "${PN}"
@@ -181,8 +182,6 @@ RDEPENDS_${PN}-dev = ""
BBCLASSEXTEND = "nativesdk"
-RPROVIDES_${PN} += "${PN}-modules"
-
# We want bytecode precompiled .py files (.pyc's) by default
# but the user may set it on their own conf