summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorHe Zhe <zhe.he@windriver.com>2018-09-28 11:18:24 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-10-03 15:25:35 +0100
commit8aa27e4eb2f08281329ca1a1da421c6fc376bc8d (patch)
tree51c5ed406d883de24e47b164a186579882acd0ee /meta/recipes-devtools
parentf72c8af3f2c1ec9e4d9ffcf0cc6e7fdf572b21b9 (diff)
downloadopenembedded-core-8aa27e4eb2f08281329ca1a1da421c6fc376bc8d.tar.gz
nativesdk-bison: Add to nativesdk-packagegroup-sdk-host and set BISON_PKGDATADIR
bison is needed when building kernel. Add it to nativesdk-packagegroup-sdk-host and set BISON_PKGDATADIR for bison to use its components. Signed-off-by: He Zhe <zhe.he@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/bison/bison_3.0.4.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta/recipes-devtools/bison/bison_3.0.4.bb b/meta/recipes-devtools/bison/bison_3.0.4.bb
index cc155f0fbe..f1b05da416 100644
--- a/meta/recipes-devtools/bison/bison_3.0.4.bb
+++ b/meta/recipes-devtools/bison/bison_3.0.4.bb
@@ -36,4 +36,8 @@ do_install_append_class-native() {
create_wrapper ${D}/${bindir}/bison \
BISON_PKGDATADIR=${STAGING_DATADIR_NATIVE}/bison
}
+do_install_append_class-nativesdk() {
+ create_wrapper ${D}/${bindir}/bison \
+ BISON_PKGDATADIR=${datadir}/bison
+}
BBCLASSEXTEND = "native nativesdk"