summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorJose Lamego <jose.a.lamego@linux.intel.com>2017-10-19 14:28:25 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-11-05 13:54:44 +0000
commit4fe7774f08ba46bd1d68e56eff3f4912db107c25 (patch)
tree331a04de1084f4d4e68bcd7c6342ebc35f743c89 /meta/recipes-devtools
parentb36100bb3077947361c858f891eb15a76013671e (diff)
downloadopenembedded-core-4fe7774f08ba46bd1d68e56eff3f4912db107c25.tar.gz
python-scons*: upgrade to 3.0.0
Both python-scons and python-scons-native need to be upgraded to latest upstream version. LIC_FILES_CHKSUM changed due to updated year in date, but rest of file remain the same. Following dependencies were added to enable appropriate package usage: python-shell, python-pprint and python-importlib. A patch was taken from upstream to support python2 print statements in SConscripts. This should be included in next version. These changes were tested in qemux86 with core-image-minimal. Signed-off-by: Jose Lamego <jose.a.lamego@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/python/python-scons-native_3.0.0.bb (renamed from meta/recipes-devtools/python/python-scons-native_2.5.1.bb)0
-rw-r--r--meta/recipes-devtools/python/python-scons/SConscript-Support-python2-print-statements.patch38
-rw-r--r--meta/recipes-devtools/python/python-scons_3.0.0.bb (renamed from meta/recipes-devtools/python/python-scons_2.5.1.bb)12
3 files changed, 46 insertions, 4 deletions
diff --git a/meta/recipes-devtools/python/python-scons-native_2.5.1.bb b/meta/recipes-devtools/python/python-scons-native_3.0.0.bb
index dae89ab5d2..dae89ab5d2 100644
--- a/meta/recipes-devtools/python/python-scons-native_2.5.1.bb
+++ b/meta/recipes-devtools/python/python-scons-native_3.0.0.bb
diff --git a/meta/recipes-devtools/python/python-scons/SConscript-Support-python2-print-statements.patch b/meta/recipes-devtools/python/python-scons/SConscript-Support-python2-print-statements.patch
new file mode 100644
index 0000000000..b1a790219e
--- /dev/null
+++ b/meta/recipes-devtools/python/python-scons/SConscript-Support-python2-print-statements.patch
@@ -0,0 +1,38 @@
+From 885aabdb313685405737112dcb7d7774eee6d879 Mon Sep 17 00:00:00 2001
+From: Thomas Berg <merlin66b@gmail.com>
+Date: Thu, 19 Oct 2017 14:02:21 -0500
+Subject: [PATCH] SConscript: Support python2 print statements
+
+This fixes a regression introduced in scons-3.0.0, where
+SConscripts containing python 2 print statements would cause
+syntax errors even when executing scons with python 2.7.
+
+This ensures backward compatibility, allowing users to build
+legacy code with scons-3.0.0 without having to patch it.
+
+Taken from
+https://github.com/SConsProject/scons/commit/2e0de3c55f22b3eaa7767b69740b898f3d2f46bf
+
+Upstream-Status: Accepted
+
+Signed-off-by: Jose Lamego <jose.a.lamego@linux.intel.com>
+---
+ engine/SCons/Script/SConscript.py | 2 --
+ 1 file changed, 2 deletions(-)
+
+diff --git a/engine/SCons/Script/SConscript.py b/engine/SCons/Script/SConscript.py
+index bc05540..332d1fa 100644
+--- a/engine/SCons/Script/SConscript.py
++++ b/engine/SCons/Script/SConscript.py
+@@ -5,8 +5,6 @@ files.
+
+ """
+
+-from __future__ import print_function
+-
+ #
+ # Copyright (c) 2001 - 2017 The SCons Foundation
+ #
+--
+2.7.4
+
diff --git a/meta/recipes-devtools/python/python-scons_2.5.1.bb b/meta/recipes-devtools/python/python-scons_3.0.0.bb
index 3f43856199..33bfb45e2e 100644
--- a/meta/recipes-devtools/python/python-scons_2.5.1.bb
+++ b/meta/recipes-devtools/python/python-scons_3.0.0.bb
@@ -1,13 +1,14 @@
SUMMARY = "Software Construction tool (make/autotools replacement)"
SECTION = "devel/python"
LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3a885dff6d14e4cd876d9008a09a42de"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=46ddf66004e5be5566367cb525a66fc6"
SRCNAME = "scons"
-SRC_URI = "https://files.pythonhosted.org/packages/source/s/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
+SRC_URI = "https://files.pythonhosted.org/packages/source/s/${SRCNAME}/${SRCNAME}-${PV}.tar.gz \
+ file://SConscript-Support-python2-print-statements.patch"
-SRC_URI[md5sum] = "3eac81e5e8206304a9b4683c57665aa4"
-SRC_URI[sha256sum] = "c8de85fc02ed1a687b1f2ac791eaa0c1707b4382a204f17d782b5b111b9fdf07"
+SRC_URI[md5sum] = "7ca558edaaa1942fe38f3105ca2400fb"
+SRC_URI[sha256sum] = "aa5afb33c2bbd33c311e47e912412195739e9ffb2e933534a31f85fba8f3470e"
UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/SCons/"
@@ -20,4 +21,7 @@ RDEPENDS_${PN} = "\
python-io \
python-json \
python-subprocess \
+ python-shell \
+ python-pprint \
+ python-importlib \
"