aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2017-01-10 18:53:19 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-01-16 18:01:54 +0000
commit7355a3c4f665e066925ea6327ac72365ab1f2f39 (patch)
tree4bd6c879ebe8261bf20eec1767721f2862fc95df /meta/recipes-devtools
parent05317fe9f11565d40b84ad71300b39c990a53f6d (diff)
downloadopenembedded-core-7355a3c4f665e066925ea6327ac72365ab1f2f39.tar.gz
python3-pygobject: add PACKAGECONFIG for cairo - enabled by default
Have onboard (onscreen-keyboard) in the pipe for meta-oe. For that working properly we need python3-pygobject build with cairo support. Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/python/python3-pygobject_3.22.0.bb10
1 files changed, 8 insertions, 2 deletions
diff --git a/meta/recipes-devtools/python/python3-pygobject_3.22.0.bb b/meta/recipes-devtools/python/python3-pygobject_3.22.0.bb
index 1c8dc2061f..5a895441fc 100644
--- a/meta/recipes-devtools/python/python3-pygobject_3.22.0.bb
+++ b/meta/recipes-devtools/python/python3-pygobject_3.22.0.bb
@@ -18,8 +18,14 @@ SRC_URI[sha256sum] = "08b29cfb08efc80f7a8630a2734dec65a99c1b59f1e5771c671d2e4ed8
S = "${WORKDIR}/${SRCNAME}-${PV}"
-BBCLASSEXTEND = "native"
-EXTRA_OECONF = "--disable-cairo"
+PACKAGECONFIG ??= "cairo"
+
+# python3-pycairo is checked on configuration -> DEPENDS
+# we don't link against python3-pycairo -> RDEPENDS
+PACKAGECONFIG[cairo] = "--enable-cairo,--disable-cairo,cairo python3-pycairo, python3-pycairo"
RDEPENDS_${PN} += "python3-setuptools python3-importlib"
+
+BBCLASSEXTEND = "native"
+PACKAGECONFIG_class-native = ""