aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2016-12-21 09:34:12 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-01-09 13:34:29 +0000
commit5ec8934a495e9b9a782889bc3a84936c8a381165 (patch)
tree35d6904937e88392018878c46aa1227482087d98 /meta/recipes-devtools
parent40c2addf0f0ee16b1c1334cf00f1490ffeaac475 (diff)
downloadopenembedded-core-5ec8934a495e9b9a782889bc3a84936c8a381165.tar.gz
opkg-utils: Do not use --ignore-fail-on-non-empty with rmdir
--ignore-fail-on-non-empty is coreutils specific, and you are not always going to have coreutils on target systems especially small ones. They will use the busybox applet which does not support --ignore-fail-on-non-empty, use pipe and true to ignore the errorcode from rmdir instead Fixes upgrade errors on target e.g. rmdir: unrecognized option '--ignore-fail-on-non-empty' BusyBox v1.24.1 (2016-12-20 10:41:39 PST) multi-call binary. Usage: rmdir [OPTIONS] DIRECTORY... To remove package debris, try `opkg remove update-alternatives-opkg`. To re-attempt the install, try `opkg install update-alternatives-opkg`. Collected errors: * pkg_run_script: package "update-alternatives-opkg" postrm script returned status 1. * postrm_upgrade_old_pkg: postrm script for package "update-alternatives-opkg" failed Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/opkg-utils/opkg-utils_git.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-devtools/opkg-utils/opkg-utils_git.bb b/meta/recipes-devtools/opkg-utils/opkg-utils_git.bb
index 7b01bfc346..4f90bcd13a 100644
--- a/meta/recipes-devtools/opkg-utils/opkg-utils_git.bb
+++ b/meta/recipes-devtools/opkg-utils/opkg-utils_git.bb
@@ -46,7 +46,7 @@ RCONFLICTS_update-alternatives-opkg = "update-alternatives-cworth"
pkg_postrm_update-alternatives-opkg() {
rm -rf $OPKG_OFFLINE_ROOT${nonarch_libdir}/opkg/alternatives
- rmdir --ignore-fail-on-non-empty $OPKG_OFFLINE_ROOT${nonarch_libdir}/opkg
+ rmdir $OPKG_OFFLINE_ROOT${nonarch_libdir}/opkg || true
}
BBCLASSEXTEND = "native nativesdk"