aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorChong Lu <Chong.Lu@windriver.com>2014-09-09 09:54:00 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-09-16 22:12:30 +0100
commit9a8b35ec689ca583bb1e117ca4998215da7fcac6 (patch)
tree0c1a6741316fa11f83eb6de6cd3e6257a4845df0 /meta/recipes-devtools
parentcc44cb2888f1ddecdd01d7bc414f7ac3043d1372 (diff)
downloadopenembedded-core-9a8b35ec689ca583bb1e117ca4998215da7fcac6.tar.gz
i2c-tools: create i2c-tools-misc package for perl scripts
The patch is to split those perl scripts from the main package. Add perl to RDEPENDS_i2c-tools-misc. Signed-off-by: Michel Thebeau <michel.thebeau@windriver.com> Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Chong Lu <Chong.Lu@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/i2c-tools/i2c-tools_3.1.1.bb12
1 files changed, 10 insertions, 2 deletions
diff --git a/meta/recipes-devtools/i2c-tools/i2c-tools_3.1.1.bb b/meta/recipes-devtools/i2c-tools/i2c-tools_3.1.1.bb
index 460541440b..71c98a4fd1 100644
--- a/meta/recipes-devtools/i2c-tools/i2c-tools_3.1.1.bb
+++ b/meta/recipes-devtools/i2c-tools/i2c-tools_3.1.1.bb
@@ -3,8 +3,6 @@ SECTION = "base"
LICENSE = "GPLv2+"
LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
-RDEPENDS_${PN} += "perl"
-
SRC_URI = "http://dl.lm-sensors.org/i2c-tools/releases/${BP}.tar.bz2 \
file://Module.mk \
"
@@ -24,3 +22,13 @@ do_install_append() {
install -m 0644 include/linux/i2c-dev.h ${D}${includedir}/linux/i2c-dev-user.h
rm -f ${D}${includedir}/linux/i2c-dev.h
}
+
+PACKAGES =+ "${PN}-misc"
+FILES_${PN}-misc = "${sbindir}/i2c-stub-from-dump \
+ ${bindir}/ddcmon \
+ ${bindir}/decode-edid \
+ ${bindir}/decode-dimms \
+ ${bindir}/decode-vaio \
+ "
+RDEPENDS_${PN} += "${PN}-misc"
+RDEPENDS_${PN}-misc += "perl"