aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2014-05-13 10:54:26 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-05-13 19:24:03 +0100
commit3c34d9391136b09bc2e7b0bda6cdc96507845c4b (patch)
tree689e49245a39524b609f896f1d1fcd3fbacdd966 /meta/recipes-devtools
parentf38c1846184722180d9091a7a5c1e6e20eed7f2c (diff)
downloadopenembedded-core-3c34d9391136b09bc2e7b0bda6cdc96507845c4b.tar.gz
gdb: add PACKAGECONFIG for babeltrace
Add PACKAGECONFIG for 'babeltrace' so that we don't have the implicit dependency which might lead to problems when building images. As an example of showing what problem we might have without this patch, see the following steps which would lead to a failure. 1. IMAGE_INSTALL_append = " gdb" 2. bitbake babeltrace 3. bitbake gdb 4. bitbake babeltrace -ccleansstate 5. bitbake core-image-minimal The rootfs process would fail with the following error message. error: Can't install gdb-7.7-r0@i586: no package provides babeltrace >= 1.2.1+git0+66c2a20b43 Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/gdb/gdb_7.7.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta/recipes-devtools/gdb/gdb_7.7.bb b/meta/recipes-devtools/gdb/gdb_7.7.bb
index c7ca26b9c1..1abc9d8e76 100644
--- a/meta/recipes-devtools/gdb/gdb_7.7.bb
+++ b/meta/recipes-devtools/gdb/gdb_7.7.bb
@@ -5,6 +5,7 @@ inherit python-dir
PACKAGECONFIG ??= ""
PACKAGECONFIG[python] = "--with-python=${WORKDIR}/python,--without-python,python"
+PACKAGECONFIG[babeltrace] = "--with-babeltrace,--without-babeltrace,babeltrace"
do_configure_prepend() {
if [ -n "${@bb.utils.contains('PACKAGECONFIG', 'python', 'python', '', d)}" ]; then