aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorTyler Hall <tylerwhall@gmail.com>2014-05-04 18:37:50 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-05-08 12:56:40 +0100
commit23849347d0fe60a01578efdd6c6e23ebb444dcd6 (patch)
tree16c8589989fc4d21d697de02d48d4ee161b862a6 /meta/recipes-devtools
parent2d01c5a4989dcf03a202c27730a2a8f334e0c37a (diff)
downloadopenembedded-core-23849347d0fe60a01578efdd6c6e23ebb444dcd6.tar.gz
python3: Substitute correct python version in shebang
If python2 and python3 are both available, scripts that are subject to this substitution can possibly run with the wrong python version. python3-config is one such script. Signed-off-by: Tyler Hall <tylerwhall@gmail.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/python/python3-native_3.3.3.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-devtools/python/python3-native_3.3.3.bb b/meta/recipes-devtools/python/python3-native_3.3.3.bb
index 7238eaf27d..0fd73498e8 100644
--- a/meta/recipes-devtools/python/python3-native_3.3.3.bb
+++ b/meta/recipes-devtools/python/python3-native_3.3.3.bb
@@ -71,6 +71,6 @@ do_install() {
# Make sure we use /usr/bin/env python
for PYTHSCRIPT in `grep -rIl ${bindir}/${PN}/python ${D}${bindir}/${PN}`; do
- sed -i -e '1s|^#!.*|#!/usr/bin/env python|' $PYTHSCRIPT
+ sed -i -e '1s|^#!.*|#!/usr/bin/env python3|' $PYTHSCRIPT
done
}