aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorSaul Wold <Saul.Wold@intel.com>2010-11-22 13:57:13 +0000
committerRichard Purdie <rpurdie@linux.intel.com>2010-11-22 13:57:13 +0000
commitcfe12efb5ec9586dab6961f141d52b103bd8b1d1 (patch)
tree7108e22aa7ddf6cfc2f1b6c6b73a811187706ecb /meta/recipes-devtools
parent762fd6b7b3b22d7a8cb80ef9e9ba62e7ef21af3e (diff)
downloadopenembedded-core-cfe12efb5ec9586dab6961f141d52b103bd8b1d1.tar.gz
Meta: Recipe Reogranization
This is the next stage of recipe reorganization, in this stage many recipes where moved to a new meta-demoapps layer since this is more appropriate for demo usage then the core. Additional some recipes were moved to meta-extras to indicate they may be depercated at a future time. A number of recipes were modified since dependencies need to be corrected. Signed-off-by: Saul Wold <Saul.Wold@intel.com>
Diffstat (limited to 'meta/recipes-devtools')
-rwxr-xr-xmeta/recipes-devtools/dpkg/run-postinsts/run-postinsts36
-rw-r--r--meta/recipes-devtools/dpkg/run-postinsts/run-postinsts.awk30
-rw-r--r--meta/recipes-devtools/dpkg/run-postinsts_1.0.bb27
-rw-r--r--meta/recipes-devtools/exmap-console/exmap-console.inc59
-rw-r--r--meta/recipes-devtools/exmap-console/exmap-console_0.4.1.bb3
-rw-r--r--meta/recipes-devtools/exmap-console/exmap-console_svn.bb8
6 files changed, 93 insertions, 70 deletions
diff --git a/meta/recipes-devtools/dpkg/run-postinsts/run-postinsts b/meta/recipes-devtools/dpkg/run-postinsts/run-postinsts
new file mode 100755
index 0000000000..f632d1c7d3
--- /dev/null
+++ b/meta/recipes-devtools/dpkg/run-postinsts/run-postinsts
@@ -0,0 +1,36 @@
+#!/bin/sh
+#
+# Copyright 2007 Openedhand Ltd.
+#
+# Author: Richard Purdie <rpurdie@openedhand.com>
+#
+
+PKGSYSTEM=/var/dpkg
+
+if [ ! -e $PKGSYSTEM/status ]; then
+ if [ -e /usr/lib/opkg/status ]; then
+ PKGSYSTEM=/usr/lib/opkg
+ else
+ echo "No package system found"
+ exit 1
+ fi
+fi
+
+STAMP=$PKGSYSTEM/postinsts-done
+STATFILE=$PKGSYSTEM/status
+STATFILE2=$PKGSYSTEM/status2
+
+if [ -e $STAMP ]; then
+ exit 0
+fi
+
+awk -f /usr/share/run-postinsts/run-postinsts.awk $STATFILE > $STATFILE2
+if [ $? = 0 ]; then
+ mv $STATFILE2 $STATFILE
+ touch $STAMP
+ exit 0
+else
+ rm -f $STATFILE2
+ rm -f $STAMP
+ exit 1
+fi
diff --git a/meta/recipes-devtools/dpkg/run-postinsts/run-postinsts.awk b/meta/recipes-devtools/dpkg/run-postinsts/run-postinsts.awk
new file mode 100644
index 0000000000..09a1400cf4
--- /dev/null
+++ b/meta/recipes-devtools/dpkg/run-postinsts/run-postinsts.awk
@@ -0,0 +1,30 @@
+#
+# Copyright 2007 Openedhand Ltd.
+#
+# Author: Richard Purdie <rpurdie@openedhand.com>
+#
+# Rather hacky proof of concept
+#
+
+BEGIN {
+ rc=system("test -d /usr/dpkg/info/")
+ if (rc==0)
+ pkgdir="/var/dpkg/info"
+ else
+ pkgdir="/usr/lib/opkg/info"
+ package=""
+}
+/Package:.*/ {
+ package = substr($0, 10)
+}
+/Status:.*unpacked.*/ {
+ print "Configuring: " package > "/dev/stderr"
+ ret = system(pkgdir "/" package ".postinst 1>&2")
+ if (ret == 0)
+ $0 = gensub("unpacked", "installed", 1)
+ else
+ print "Postinstall failed for " package > "/dev/stderr"
+}
+{
+ print $0
+}
diff --git a/meta/recipes-devtools/dpkg/run-postinsts_1.0.bb b/meta/recipes-devtools/dpkg/run-postinsts_1.0.bb
new file mode 100644
index 0000000000..44e840ed13
--- /dev/null
+++ b/meta/recipes-devtools/dpkg/run-postinsts_1.0.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "Run postinstall scripts on device using awk"
+SECTION = "devel"
+PR = "r6"
+LICENSE = "MIT"
+
+SRC_URI = "file://run-postinsts file://run-postinsts.awk"
+
+INITSCRIPT_NAME = "run-postinsts"
+INITSCRIPT_PARAMS = "start 98 S ."
+
+inherit update-rc.d
+
+do_configure() {
+ :
+}
+
+do_compile () {
+ :
+}
+
+do_install() {
+ install -d ${D}${sysconfdir}/init.d/
+ install -m 0755 ${WORKDIR}/run-postinsts ${D}${sysconfdir}/init.d/
+
+ install -d ${D}${datadir}/${PN}/
+ install -m 0644 ${WORKDIR}/run-postinsts.awk ${D}${datadir}/${PN}/
+}
diff --git a/meta/recipes-devtools/exmap-console/exmap-console.inc b/meta/recipes-devtools/exmap-console/exmap-console.inc
deleted file mode 100644
index efbd79fce1..0000000000
--- a/meta/recipes-devtools/exmap-console/exmap-console.inc
+++ /dev/null
@@ -1,59 +0,0 @@
-DESCRIPTION = "Console based version of exmap, a memory usage analysis tool"
-HOMEPAGE = "http://projects.o-hand.com/exmap-console"
-SECTION = "devel"
-LICENSE = "GPL"
-DEPENDS = "virtual/kernel readline glib-2.0"
-
-SRC_URI = "http://projects.o-hand.com/sources/exmap-console/exmap-console-${PV}.tgz"
-
-TEMPPACKAGE_ARCH := "${PACKAGE_ARCH}"
-
-inherit module-base
-inherit autotools
-
-PACKAGE_ARCH = "${TEMPPACKAGE_ARCH}"
-
-PACKAGES =+ "exmap-server kernel-module-exmap"
-
-FILES_exmap-console = "${bindir}/exmap ${bindir}/exmapd"
-RDEPENDS_exmap-console += "kernel-module-exmap"
-
-FILES_exmap-server = "${bindir}/exmapserver"
-RDEPENDS_exmap-server += "kernel-module-exmap"
-
-FILES_kernel-module-exmap = "${base_libdir}"
-PACKAGE_ARCH_kernel-module-exmap = "${MACHINE_ARCH}"
-RDEPENDS_kernel-module-exmap += "update-modules kernel-image-${KERNEL_VERSION}"
-
-S = "${WORKDIR}/exmap-console-${PV}"
-
-export MODULE_PATH="${D}${base_libdir}/modules/${KERNEL_VERSION}"
-
-do_compile() {
- cd ${S}/src
- make
-
- cd ${S}/kernel
- unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
- oe_runmake KERNEL_PATH=${STAGING_KERNEL_DIR} \
- KERNEL_SRC=${STAGING_KERNEL_DIR} \
- KERNEL_VERSION=${KERNEL_VERSION} \
- CC="${KERNEL_CC}" LD="${KERNEL_LD}" \
- ${MAKE_TARGETS}
-}
-
-do_install() {
- oe_runmake 'DESTDIR=${D}' 'DEPMOD=/bin/true' install
-}
-
-pkg_postinst_append_kernel-module-exmap () {
- if [ -n "$D" ]; then
- exit 1
- fi
- depmod -a
- update-modules || true
-}
-
-pkg_postrm_append_kernel-module-exmap () {
- update-modules || true
-}
diff --git a/meta/recipes-devtools/exmap-console/exmap-console_0.4.1.bb b/meta/recipes-devtools/exmap-console/exmap-console_0.4.1.bb
deleted file mode 100644
index c76c5c3b4c..0000000000
--- a/meta/recipes-devtools/exmap-console/exmap-console_0.4.1.bb
+++ /dev/null
@@ -1,3 +0,0 @@
-require exmap-console.inc
-
-PR = "r8"
diff --git a/meta/recipes-devtools/exmap-console/exmap-console_svn.bb b/meta/recipes-devtools/exmap-console/exmap-console_svn.bb
deleted file mode 100644
index ce222854e2..0000000000
--- a/meta/recipes-devtools/exmap-console/exmap-console_svn.bb
+++ /dev/null
@@ -1,8 +0,0 @@
-require exmap-console.inc
-
-PV = "0.4+svnr${SRCREV}"
-PR = "r5"
-
-SRC_URI = "svn://svn.o-hand.com/repos/misc/trunk;module=exmap-console;proto=http"
-
-S = "${WORKDIR}/exmap-console"