aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2012-07-18 17:38:05 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-07-18 22:17:44 +0100
commitcf63d9068c3a8c635dfc240d30dfff278be9b0e2 (patch)
treecfc9d719c77ef4182eea224f2d692c56d732bba1 /meta/recipes-devtools
parent7d49af3a811472a2a47453bef0813b89c6331ae7 (diff)
downloadopenembedded-core-cf63d9068c3a8c635dfc240d30dfff278be9b0e2.tar.gz
bitbake.conf: Define USRBINPATH globally instead of individually
Many recipes are now having to define PERLPATH and PYTHONPATH variables. Creating USRBINPATH in bitbake.conf means we can remove all these lines from the many recipes now needing this and simplify the code changes needed in each case, reducing the chance of errors being introduced. Also fixup glib python binary location issue and fix function indentation. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/autoconf/autoconf.inc8
-rw-r--r--meta/recipes-devtools/automake/automake_1.12.1.bb8
-rw-r--r--meta/recipes-devtools/quilt/quilt_0.60.bb5
3 files changed, 5 insertions, 16 deletions
diff --git a/meta/recipes-devtools/autoconf/autoconf.inc b/meta/recipes-devtools/autoconf/autoconf.inc
index 3ae98c8407..2c077011f8 100644
--- a/meta/recipes-devtools/autoconf/autoconf.inc
+++ b/meta/recipes-devtools/autoconf/autoconf.inc
@@ -17,10 +17,6 @@ SRC_URI = "${GNU_MIRROR}/autoconf/autoconf-${PV}.tar.bz2 \
inherit autotools
-PERLPATH = "${bindir}/perl"
-PERLPATH_virtclass-native = "/usr/bin/perl"
-PERLPATH_virtclass-nativesdk = "/usr/bin/perl"
-
do_install_append() {
rm -rf ${D}${datadir}/emacs
@@ -28,8 +24,8 @@ do_install_append() {
# for target as /usr/bin/perl, so fix it to /usr/bin/perl.
for i in autoheader autom4te autoreconf autoscan autoupdate ifnames; do
if [ -f ${D}${bindir}/$i ]; then
- sed -i -e '1s,#!.*perl,#! ${PERLPATH},' \
- -e 's,exec .*/bin/perl \(.*\) exec .*/bin/perl \(.*\),exec ${PERLPATH} \1 exec ${PERLPATH} \2,' \
+ sed -i -e '1s,#!.*perl,#! ${USRBINPATH}/perl,' \
+ -e 's,exec .*/bin/perl \(.*\) exec .*/bin/perl \(.*\),exec ${USRBINPATH}/perl \1 exec ${USRBINPATH}/perl \2,' \
${D}${bindir}/$i
fi
done
diff --git a/meta/recipes-devtools/automake/automake_1.12.1.bb b/meta/recipes-devtools/automake/automake_1.12.1.bb
index c2bc6a3068..a1e37d471c 100644
--- a/meta/recipes-devtools/automake/automake_1.12.1.bb
+++ b/meta/recipes-devtools/automake/automake_1.12.1.bb
@@ -34,10 +34,6 @@ PATHFIXPATCH = "file://path_prog_fixes.patch"
PATHFIXPATCH_virtclass-native = ""
PATHFIXPATCH_virtclass-nativesdk = ""
-PERLPATH = "${bindir}/perl"
-PERLPATH_virtclass-native = "/usr/bin/perl"
-PERLPATH_virtclass-nativesdk = "/usr/bin/perl"
-
SRC_URI += "${PATHFIXPATCH} \
file://prefer-cpio-over-pax-for-ustar-archives.patch \
file://python-libdir.patch \
@@ -56,8 +52,8 @@ do_install () {
# for target as /usr/bin/perl, so fix it to /usr/bin/perl.
for i in aclocal aclocal-1.11 automake automake-1.11; do
if [ -f ${D}${bindir}/$i ]; then
- sed -i -e '1s,#!.*perl,#! ${PERLPATH},' \
- -e 's,exec .*/bin/perl \(.*\) exec .*/bin/perl \(.*\),exec ${PERLPATH} \1 exec ${PERLPATH} \2,' \
+ sed -i -e '1s,#!.*perl,#! ${USRBINPATH}/perl,' \
+ -e 's,exec .*/bin/perl \(.*\) exec .*/bin/perl \(.*\),exec ${USRBINPATH}/perl \1 exec ${USRBINPATH}/perl \2,' \
${D}${bindir}/$i
fi
done
diff --git a/meta/recipes-devtools/quilt/quilt_0.60.bb b/meta/recipes-devtools/quilt/quilt_0.60.bb
index 89c3f84f39..d866032188 100644
--- a/meta/recipes-devtools/quilt/quilt_0.60.bb
+++ b/meta/recipes-devtools/quilt/quilt_0.60.bb
@@ -9,15 +9,12 @@ PR = "r1"
CACHED_CONFIGUREVARS += "ac_cv_path_BASH=${base_bindir}/bash"
-PERLPATH = "${bindir}/env perl"
-PERLPATH_virtclass-nativesdk = "/usr/bin/env perl"
-
# fix build-distro specific perl path in the target perl scripts
do_install_append() {
for perlscript in ${D}${datadir}/quilt/scripts/remove-trailing-ws ${D}${datadir}/quilt/scripts/dependency-graph ${D}${datadir}/quilt/scripts/edmail ${D}${bindir}/guards
do
if [ -f $perlscript ]; then
- sed -i -e '1s,#!.*perl,#! ${PERLPATH},' $perlscript
+ sed -i -e '1s,#!.*perl,#! ${USRBINPATH}/env perl,' $perlscript
fi
done
}