aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2013-01-07 19:42:39 -0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-01-07 22:37:21 +0000
commit8dd608dac1e5658197078d002dc1b3dc8ac83184 (patch)
tree5e8f73b0121d0702126fada79d9d735a2fbc57b7 /meta/recipes-devtools
parente7c9706d6a6777326a62e73bffdbb0f940792ff4 (diff)
downloadopenembedded-core-8dd608dac1e5658197078d002dc1b3dc8ac83184.tar.gz
perl: Remove bashism from perl-tests.inc
The perl-tests.inc file where using the constructs: cp {a,b} to/ but this is not supported in every shell so we cannot use it. This patch fixes it. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/perl/perl-tests.inc7
-rw-r--r--meta/recipes-devtools/perl/perl_5.14.2.bb2
2 files changed, 5 insertions, 4 deletions
diff --git a/meta/recipes-devtools/perl/perl-tests.inc b/meta/recipes-devtools/perl/perl-tests.inc
index c968eb645b..e6de088769 100644
--- a/meta/recipes-devtools/perl/perl-tests.inc
+++ b/meta/recipes-devtools/perl/perl-tests.inc
@@ -21,12 +21,13 @@ do_install_append () {
cp -pv lib/AnyDBM_File.t ${D}${libdir}/perl/${PV}/
mkdir -p ${D}${libdir}/perl/${PV}/XS
- cp -pv lib/XS/{APItest,Typemap}.pm ${D}${libdir}/perl/${PV}/XS/
+ cp -pv lib/XS/APItest.pm ${D}${libdir}/perl/${PV}/XS/
+ cp -pv lib/XS/Typemap.pm ${D}${libdir}/perl/${PV}/XS/
mkdir -p ${D}${libdir}/perl/${PV}/auto/XS/APItest
cp -pv lib/auto/XS/APItest/APItest.so ${D}${libdir}/perl/${PV}/auto/XS/APItest/
cp -pv lib/auto/XS/Typemap/Typemap.so ${D}${libdir}/perl/${PV}/auto/XS/Typemap/
-
- cp -pv cpan/Digest-MD5/{README,MD5.xs} ${D}${PERL_TEST_DIR}/cpan/Digest-MD5/
+ cp -pv cpan/Digest-MD5/README ${D}${PERL_TEST_DIR}/cpan/Digest-MD5/
+ cp -pv cpan/Digest-MD5/MD5.xs ${D}${PERL_TEST_DIR}/cpan/Digest-MD5/
}
FILES_${PN}-tests = "${PERL_TEST_DIR} \
diff --git a/meta/recipes-devtools/perl/perl_5.14.2.bb b/meta/recipes-devtools/perl/perl_5.14.2.bb
index 8678e76dec..e62e8ec657 100644
--- a/meta/recipes-devtools/perl/perl_5.14.2.bb
+++ b/meta/recipes-devtools/perl/perl_5.14.2.bb
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://Copying;md5=2b4c6ffbcfcbdee469f02565f253d81a \
# We need gnugrep (for -I)
DEPENDS = "virtual/db grep-native"
DEPENDS += "gdbm zlib"
-PR = "r16"
+PR = "r17"
# 5.10.1 has Module::Build built-in
PROVIDES += "libmodule-build-perl"