aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/rpm/rpm
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2011-03-03 08:09:06 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-03-03 23:30:32 +0000
commitbcdd048e4857b5f8a343c434ade5a02ab1db33bc (patch)
tree0259e7aad65df17e51aa6b731d360063d4f1a7ca /meta/recipes-devtools/rpm/rpm
parentcbe1b8277c610e8e31d1270757877300532bed56 (diff)
downloadopenembedded-core-bcdd048e4857b5f8a343c434ade5a02ab1db33bc.tar.gz
rpm: Fix linking error encountered in rpm-native
* This patch passes the correct LDFLAGS to account for additional dependencies of librpmio on libbeecrypt and libsyck and hence fixes the build error. Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/rpm/rpm')
-rw-r--r--meta/recipes-devtools/rpm/rpm/rpm-tools-mtree-LDFLAGS.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta/recipes-devtools/rpm/rpm/rpm-tools-mtree-LDFLAGS.patch b/meta/recipes-devtools/rpm/rpm/rpm-tools-mtree-LDFLAGS.patch
new file mode 100644
index 0000000000..9e7bba0475
--- /dev/null
+++ b/meta/recipes-devtools/rpm/rpm/rpm-tools-mtree-LDFLAGS.patch
@@ -0,0 +1,24 @@
+Source: None
+Status: Needs to go Upstream
+Author: Khem Raj <raj.khem@gmail.com>
+Date: 2011-03-03
+Description:
+This patch fixes build issue found when compiling rpm-natibe on ubuntu
+11.04-alpha. Problem is that linker does not get correct set of dependent
+libraries when linking mtree binary which results in undefined symbols
+in librpmio.so. This patch adds correct flags to mtree_LDADD to account
+for rpmio deps
+
+Index: rpm-5.4.0/tools/Makefile.am
+===================================================================
+--- rpm-5.4.0.orig/tools/Makefile.am
++++ rpm-5.4.0/tools/Makefile.am
+@@ -169,7 +169,7 @@ grep_LDADD = $(RPMIO_LDADD_COMMON)
+
+ mtree_SOURCES = rpmmtree.c
+ mtree_LDFLAGS = @LDFLAGS_STATIC@ $(LDFLAGS)
+-mtree_LDADD = $(RPM_LDADD_COMMON)
++mtree_LDADD = $(RPMIO_LDADD_COMMON)
+
+ rpmrepo_SOURCES = rpmrepo.c
+ rpmrepo_CPPFLAGS = $(AM_CPPFLAGS) -I$(top_srcdir)/scripts -I$(top_builddir)/scripts $(CPPFLAGS)