aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/qemu
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2013-02-28 23:01:51 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-03-05 12:29:45 +0000
commitf479201fffda617e3530967a75ab350739574b4b (patch)
tree9b3689a04630fe16d8945d6c3d2820a855a9b8ab /meta/recipes-devtools/qemu
parent97403b14765331c8c48bb570c6b98f2809214a9a (diff)
downloadopenembedded-core-f479201fffda617e3530967a75ab350739574b4b.tar.gz
qemu: Upgrade to 1.4.0 release
Tested qemu on x86-64 target and qemu-native no obvious problems seen in testing Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-devtools/qemu')
-rw-r--r--meta/recipes-devtools/qemu/files/fix-configure-checks.patch10
-rw-r--r--meta/recipes-devtools/qemu/files/relocatable_sdk.patch16
-rw-r--r--meta/recipes-devtools/qemu/qemu.inc2
-rw-r--r--meta/recipes-devtools/qemu/qemu_1.4.0.bb (renamed from meta/recipes-devtools/qemu/qemu_1.3.1.bb)6
4 files changed, 16 insertions, 18 deletions
diff --git a/meta/recipes-devtools/qemu/files/fix-configure-checks.patch b/meta/recipes-devtools/qemu/files/fix-configure-checks.patch
index ef77c92842..294c22019d 100644
--- a/meta/recipes-devtools/qemu/files/fix-configure-checks.patch
+++ b/meta/recipes-devtools/qemu/files/fix-configure-checks.patch
@@ -8,14 +8,14 @@ Patch from Paul Eggleton, Comments by RP 28/11/10
Upstream-Status: Inappropriate [embedded specific]
-Index: qemu-1.2.0/configure
+Index: qemu-1.4.0/configure
===================================================================
---- qemu-1.2.0.orig/configure 2012-09-05 07:03:06.000000000 -0700
-+++ qemu-1.2.0/configure 2012-09-06 13:55:07.007793823 -0700
-@@ -281,6 +281,7 @@
+--- qemu-1.4.0.orig/configure 2013-02-15 15:05:35.000000000 -0800
++++ qemu-1.4.0/configure 2013-02-25 13:44:17.915273181 -0800
+@@ -286,6 +286,7 @@
QEMU_CFLAGS="-Wstrict-prototypes -Wredundant-decls $QEMU_CFLAGS"
QEMU_CFLAGS="-D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE $QEMU_CFLAGS"
- QEMU_INCLUDES="-I. -I\$(SRC_PATH) -I\$(SRC_PATH)/fpu"
+ QEMU_INCLUDES="-I. -I\$(SRC_PATH) -I\$(SRC_PATH)/include"
+QEMU_CFLAGS="$QEMU_CFLAGS $CFLAGS"
if test "$debug_info" = "yes"; then
CFLAGS="-g $CFLAGS"
diff --git a/meta/recipes-devtools/qemu/files/relocatable_sdk.patch b/meta/recipes-devtools/qemu/files/relocatable_sdk.patch
index 0a01a8a048..774a49c774 100644
--- a/meta/recipes-devtools/qemu/files/relocatable_sdk.patch
+++ b/meta/recipes-devtools/qemu/files/relocatable_sdk.patch
@@ -6,11 +6,11 @@ the new path (4096 is the maximum path length in Linux).
Signed-off-by: Laurentiu Palcu <laurentiu.palcu@intel.com>
-Index: qemu-1.2.0/i386.ld
+Index: qemu-1.4.0/ldscripts/i386.ld
===================================================================
---- qemu-1.2.0.orig/i386.ld
-+++ qemu-1.2.0/i386.ld
-@@ -8,7 +8,7 @@ SECTIONS
+--- qemu-1.4.0.orig/ldscripts/i386.ld 2013-02-15 15:05:35.000000000 -0800
++++ qemu-1.4.0/ldscripts/i386.ld 2013-02-28 22:55:36.138816418 -0800
+@@ -8,7 +8,7 @@
{
/* Read-only sections, merged into text segment: */
. = 0x60000000 + SIZEOF_HEADERS;
@@ -19,11 +19,11 @@ Index: qemu-1.2.0/i386.ld
.hash : { *(.hash) }
.dynsym : { *(.dynsym) }
.dynstr : { *(.dynstr) }
-Index: qemu-1.2.0/x86_64.ld
+Index: qemu-1.4.0/ldscripts/x86_64.ld
===================================================================
---- qemu-1.2.0.orig/x86_64.ld
-+++ qemu-1.2.0/x86_64.ld
-@@ -6,7 +6,7 @@ SECTIONS
+--- qemu-1.4.0.orig/ldscripts/x86_64.ld 2013-02-15 15:05:35.000000000 -0800
++++ qemu-1.4.0/ldscripts/x86_64.ld 2013-02-28 22:55:36.138816418 -0800
+@@ -6,7 +6,7 @@
{
/* Read-only sections, merged into text segment: */
. = 0x60000000 + SIZEOF_HEADERS;
diff --git a/meta/recipes-devtools/qemu/qemu.inc b/meta/recipes-devtools/qemu/qemu.inc
index eb60d43344..5616a06335 100644
--- a/meta/recipes-devtools/qemu/qemu.inc
+++ b/meta/recipes-devtools/qemu/qemu.inc
@@ -32,7 +32,7 @@ SRC_URI_append_class-nativesdk = "\
file://relocatable_sdk.patch \
"
-EXTRA_OECONF += "--target-list=${@get_qemu_target_list(d)} --disable-werror --disable-vnc-tls --audio-drv-list=oss,alsa --audio-card-list=ac97,es1370 ${SDL} --disable-curl --disable-vnc-jpeg --disable-bluez --with-system-pixman --disable-smartcard"
+EXTRA_OECONF += "--target-list=${@get_qemu_target_list(d)} --disable-werror --disable-vnc-tls --audio-drv-list=oss,alsa --audio-card-list=ac97,es1370 ${SDL} --disable-curl --disable-vnc-jpeg --disable-bluez --with-system-pixman"
EXTRA_OECONF_class-nativesdk = "--target-list=${@get_qemu_target_list(d)} --disable-werror --disable-vnc-tls \
--disable-curl \
diff --git a/meta/recipes-devtools/qemu/qemu_1.3.1.bb b/meta/recipes-devtools/qemu/qemu_1.4.0.bb
index c04b2be9f9..009cd78337 100644
--- a/meta/recipes-devtools/qemu/qemu_1.3.1.bb
+++ b/meta/recipes-devtools/qemu/qemu_1.4.0.bb
@@ -4,7 +4,5 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=441c28d2cf86e15a37fa47e15a72fbac \
file://COPYING.LIB;endline=24;md5=c04def7ae38850e7d3ef548588159913"
SRC_URI_prepend = "http://wiki.qemu.org/download/qemu-${PV}.tar.bz2"
-SRC_URI[md5sum] = "5dbc6c22f47efca71dfaae0dd80dcf9e"
-SRC_URI[sha256sum] = "3772e7ef0c9b4178195edcf90e711f12ba123f465fcf09fb43b56bdacaca0eaf"
-
-PR = "r0"
+SRC_URI[md5sum] = "78f13b774814b6b7ebcaf4f9b9204318"
+SRC_URI[sha256sum] = "066297ed77408fb7588889c271a85cf3c259ad55c939315988e6062d7708eda8"