aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/qemu
diff options
context:
space:
mode:
authorPhil Blundell <pb@pbcl.net>2014-01-09 11:18:26 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-01-10 15:12:16 +0000
commitcd962b790d5d15985a5a436169d6b2e3b0db0b2d (patch)
treee60c59aee4b574192ab69cb4eeb92a8f0929b6b9 /meta/recipes-devtools/qemu
parent21ba0297409bfc6e0fb89f45c9bfed8981c7df5b (diff)
downloadopenembedded-core-cd962b790d5d15985a5a436169d6b2e3b0db0b2d.tar.gz
qemu: Remove stray .git files after unpacking
The qemu tarball ships some extraneous .git metadata in the dtc/ and pixman/ subfolders, containing a reference to the path "../.git/modules" which doesn't exist. The presence of these files will confuse git if it happens to recurse into the qemu source folder during an operation on some parent directory, for example "git clean" at a higher level. Avoid that problem (mostly) by removing them immediately after the sources are unpacked. Signed-off-by: Phil Blundell <pb@pbcl.net> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/qemu')
-rw-r--r--meta/recipes-devtools/qemu/qemu_1.7.0.bb8
1 files changed, 8 insertions, 0 deletions
diff --git a/meta/recipes-devtools/qemu/qemu_1.7.0.bb b/meta/recipes-devtools/qemu/qemu_1.7.0.bb
index d5265bcf57..c0e8b5523e 100644
--- a/meta/recipes-devtools/qemu/qemu_1.7.0.bb
+++ b/meta/recipes-devtools/qemu/qemu_1.7.0.bb
@@ -11,6 +11,14 @@ SRC_URI[sha256sum] = "31f333a85f2d14c605a77679904a9668eaeb1b6dc7da53a1665230f46b
COMPATIBLE_HOST_class-target_mips64 = "null"
+do_sanitize_sources() {
+ # These .git files point to a nonexistent path "../.git/modules" and will confuse git
+ # if it tries to recurse into those directories.
+ rm -f ${S}/dtc/.git ${S}/pixman/.git
+}
+
+addtask sanitize_sources after do_unpack before do_patch
+
do_install_append() {
# Prevent QA warnings about installed ${localstatedir}/run
if [ -d ${D}${localstatedir}/run ]; then rmdir ${D}${localstatedir}/run; fi