aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/qemu/qemu-1.2.0/linker-flags-2.patch
diff options
context:
space:
mode:
authorTrevor Woerner <twoerner@gmail.com>2013-05-07 13:37:14 -0400
committerRoss Burton <ross.burton@intel.com>2013-05-08 12:03:12 +0100
commitc0ed6d8017eb83321dfb6e5c769cce2c9f81ca0c (patch)
tree077f03cd4c4b092b5350542b3a6e4ff4e7dc8a3c /meta/recipes-devtools/qemu/qemu-1.2.0/linker-flags-2.patch
parent6091d041e94397a4dda6827868ba48d2e3250d26 (diff)
downloadopenembedded-core-c0ed6d8017eb83321dfb6e5c769cce2c9f81ca0c.tar.gz
qemu-native: fix DSO linking
I noticed this issue trying to build using the Danny branch on what is currently the most recent openSuSE (12.3). It appears to be similar to the fedora DSO linking issue: https://fedoraproject.org/wiki/UnderstandingDSOLinkChange. Upstream-status: Inappropriate [OE Specific] Signed-off-by: Trevor Woerner <twoerner@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools/qemu/qemu-1.2.0/linker-flags-2.patch')
-rw-r--r--meta/recipes-devtools/qemu/qemu-1.2.0/linker-flags-2.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta/recipes-devtools/qemu/qemu-1.2.0/linker-flags-2.patch b/meta/recipes-devtools/qemu/qemu-1.2.0/linker-flags-2.patch
new file mode 100644
index 0000000000..ba50c8d5d2
--- /dev/null
+++ b/meta/recipes-devtools/qemu/qemu-1.2.0/linker-flags-2.patch
@@ -0,0 +1,26 @@
+diff -urN qemu-1.2.0.orig/Makefile qemu-1.2.0/Makefile
+--- qemu-1.2.0.orig/Makefile 2012-09-05 10:03:06.000000000 -0400
++++ qemu-1.2.0/Makefile 2013-05-07 12:18:23.638560591 -0400
+@@ -172,7 +172,7 @@
+ qemu-img-cmds.h: $(SRC_PATH)/qemu-img-cmds.hx
+ $(call quiet-command,sh $(SRC_PATH)/scripts/hxtool -h < $< > $@," GEN $@")
+
+-qemu-ga$(EXESUF): LIBS = $(LIBS_QGA)
++qemu-ga$(EXESUF): LIBS = $(LIBS_QGA) -lrt
+ qemu-ga$(EXESUF): QEMU_CFLAGS += -I qga/qapi-generated
+
+ gen-out-type = $(subst .,-,$(suffix $@))
+diff -urN qemu-1.2.0.orig/configure qemu-1.2.0/configure
+--- qemu-1.2.0.orig/configure 2012-09-05 10:03:06.000000000 -0400
++++ qemu-1.2.0/configure 2013-05-07 12:11:06.940307455 -0400
+@@ -2681,6 +2681,10 @@
+ LIBS="-lrt $LIBS"
+ fi
+
++if test "$linux" = "yes" ; then
++ LIBS="-lrt $LIBS"
++fi
++
+ if test "$darwin" != "yes" -a "$mingw32" != "yes" -a "$solaris" != yes -a \
+ "$aix" != "yes" -a "$haiku" != "yes" ; then
+ libs_softmmu="-lutil $libs_softmmu"