aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python
diff options
context:
space:
mode:
authorLaurentiu Palcu <laurentiu.palcu@intel.com>2013-11-05 11:25:17 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-11-05 22:17:51 +0000
commitbeaa98867954898f75c8a0987218a2caffb8daba (patch)
tree557fbb168d0b7c740ae193ad11f004d22d557083 /meta/recipes-devtools/python
parentf5bf674d0497a094682609b74da018e040f8d150 (diff)
downloadopenembedded-core-beaa98867954898f75c8a0987218a2caffb8daba.tar.gz
python-pycurl: upgrade to 7.19.0.2
Refreshed no-static-link.patch to work with this release and changed the lines/checksum (and the file) where the license can be found. Signed-off-by: Laurentiu Palcu <laurentiu.palcu@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python')
-rw-r--r--meta/recipes-devtools/python/python-pycurl/no-static-link.patch25
-rw-r--r--meta/recipes-devtools/python/python-pycurl_7.19.0.2.bb (renamed from meta/recipes-devtools/python/python-pycurl_7.19.0.bb)7
2 files changed, 15 insertions, 17 deletions
diff --git a/meta/recipes-devtools/python/python-pycurl/no-static-link.patch b/meta/recipes-devtools/python/python-pycurl/no-static-link.patch
index c97f5dc029..e8c0005a77 100644
--- a/meta/recipes-devtools/python/python-pycurl/no-static-link.patch
+++ b/meta/recipes-devtools/python/python-pycurl/no-static-link.patch
@@ -1,16 +1,15 @@
Upstream-Status: Pending
-Index: pycurl-7.18.2/setup.py
+Index: pycurl-7.19.0.2/setup.py
===================================================================
---- pycurl-7.18.2.orig/setup.py
-+++ pycurl-7.18.2/setup.py
-@@ -97,8 +97,7 @@ else:
- else:
- extra_compile_args.append(e)
- libs = split_quoted(
-- os.popen("'%s' --libs" % CURL_CONFIG).read()+\
-- os.popen("'%s' --static-libs" % CURL_CONFIG).read())
-+ os.popen("'%s' --libs" % CURL_CONFIG).read())
- for e in libs:
- if e[:2] == "-l":
- libraries.append(e[2:])
+--- pycurl-7.19.0.2.orig/setup.py 2013-10-08 15:28:53.000000000 +0300
++++ pycurl-7.19.0.2/setup.py 2013-11-04 13:46:47.928292585 +0200
+@@ -101,7 +101,7 @@
+ # support one or the other of these curl-config options, so gracefully
+ # tolerate failure of either, but not both.
+ optbuf = ""
+- for option in ["--libs", "--static-libs"]:
++ for option in ["--libs"]:
+ p = subprocess.Popen("'%s' %s" % (CURL_CONFIG, option), shell=True,
+ stdout=subprocess.PIPE)
+ (stdout, stderr) = p.communicate()
diff --git a/meta/recipes-devtools/python/python-pycurl_7.19.0.bb b/meta/recipes-devtools/python/python-pycurl_7.19.0.2.bb
index 122e1bdedc..fb57b49a93 100644
--- a/meta/recipes-devtools/python/python-pycurl_7.19.0.bb
+++ b/meta/recipes-devtools/python/python-pycurl_7.19.0.2.bb
@@ -2,22 +2,21 @@ DESCRIPTION = "libcurl python bindings."
HOMEPAGE = "http://pycurl.sourceforge.net/"
SECTION = "devel/python"
LICENSE = "LGPLv2.1+ | MIT"
-LIC_FILES_CHKSUM = "file://README;endline=13;md5=fbfe545b1869617123a08c0983ef17b2 \
+LIC_FILES_CHKSUM = "file://README.rst;beginline=97;endline=111;md5=b5a5e531d80812bcbecbeb240fde63ef \
file://COPYING;md5=3579a9fd0221d49a237aaa33492f988c \
file://COPYING2;md5=ffaa1e283b7f9bf5aafd8d45db6f7518"
DEPENDS = "curl python"
RDEPENDS_${PN} = "python-core curl"
SRCNAME = "pycurl"
-PR = "r3"
SRC_URI = "\
http://${SRCNAME}.sourceforge.net/download/${SRCNAME}-${PV}.tar.gz;name=archive \
file://no-static-link.patch \
"
-SRC_URI[archive.md5sum] = "919d58fe37e69fe87ce4534d8b6a1c7b"
-SRC_URI[archive.sha256sum] = "eb782dfcc5a7c023539a077462b83c167e178128ee9f7201665b9fbb1a8b0642"
+SRC_URI[archive.md5sum] = "518be33976dbc6838e42495ada64b43f"
+SRC_URI[archive.sha256sum] = "7a9e793b9181654d5eef3f6d22c244c57d2b51d38feb4c1b71d68efda99b0547"
S = "${WORKDIR}/${SRCNAME}-${PV}"
inherit distutils