aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2014-01-14 15:19:28 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-01-14 16:21:37 +0000
commit6b0c3e9955292d2ea13c6871c686824cd04150f1 (patch)
tree0960a2243a6a8ad85df9f7c7142929c37cfcb8df /meta/recipes-devtools/python
parent1ad759508d834f3bcb3bb8542ae2012a2b6ef2e0 (diff)
downloadopenembedded-core-6b0c3e9955292d2ea13c6871c686824cd04150f1.tar.gz
python-nose: add (from meta-oe)
python-nose is a build dependecy for python-numpy, needed for Piglit. This recipe is taken directly from meta-oe. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python')
-rw-r--r--meta/recipes-devtools/python/python-nose_1.2.1.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-nose_1.2.1.bb b/meta/recipes-devtools/python/python-nose_1.2.1.bb
new file mode 100644
index 0000000000..083d0521df
--- /dev/null
+++ b/meta/recipes-devtools/python/python-nose_1.2.1.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "nose extends the test loading and running features of unittest, \
+making it easier to write, find and run tests."
+SECTION = "devel/python"
+LICENSE = "LGPLv2.1"
+LIC_FILES_CHKSUM = "file://lgpl.txt;md5=a6f89e2100d9b6cdffcea4f398e37343"
+
+SRC_URI = "http://pypi.python.org/packages/source/n/nose/nose-${PV}.tar.gz"
+
+SRC_URI[md5sum] = "735e3f1ce8b07e70ee1b742a8a53585a"
+SRC_URI[sha256sum] = "2171e9202d118d302d5db1decb52dd862b79e2a626ca19653a6914574a6ca7d9"
+
+S = "${WORKDIR}/nose-${PV}"
+
+inherit distutils