aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python
diff options
context:
space:
mode:
authorYue Tao <Yue.Tao@windriver.com>2013-11-28 16:34:48 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-12-03 12:51:03 +0000
commit1181112cf65bc0186807fc59399c5dddcb9f9449 (patch)
tree6f95a6734d9f90fea676f5d0f8662a2ddf18d102 /meta/recipes-devtools/python
parentf57c83fc33583c140f668946f3f3e79b960aa9ee (diff)
downloadopenembedded-core-1181112cf65bc0186807fc59399c5dddcb9f9449.tar.gz
python: do not replace ccache in the middle of a path
Python recipe did a sed s/ccache/$(CCACHE) on the Makefile, which replaces all "ccache" including ones that consist of a full path. This leads to build error when building in a project path with "ccache" in its name. Fix it by only replacing "ccache " with "$(CCACHE) ". Signed-off-by: Lei Liu <lei.liu2@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python')
-rw-r--r--meta/recipes-devtools/python/python_2.7.3.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-devtools/python/python_2.7.3.bb b/meta/recipes-devtools/python/python_2.7.3.bb
index 887e02e1c3..b560b82754 100644
--- a/meta/recipes-devtools/python/python_2.7.3.bb
+++ b/meta/recipes-devtools/python/python_2.7.3.bb
@@ -61,7 +61,7 @@ do_compile() {
cd -
# remove hardcoded ccache, see http://bugs.openembedded.net/show_bug.cgi?id=4144
- sed -i -e s,ccache,'$(CCACHE)', Makefile
+ sed -i -e s,ccache\ ,'$(CCACHE) ', Makefile
# remove any bogus LD_LIBRARY_PATH
sed -i -e s,RUNSHARED=.*,RUNSHARED=, Makefile