aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python
diff options
context:
space:
mode:
authorBogdan Marinescu <bogdan.a.marinescu@intel.com>2013-01-29 11:05:02 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-02-01 15:51:30 +0000
commit03c892a02568fa8a5765d9fb569a55f17ea05f96 (patch)
tree38ae50c91db4b63ef19993c6c33f38e335522e66 /meta/recipes-devtools/python
parentd5314f90747a09967fcbcccec8d86b1e2f48980d (diff)
downloadopenembedded-core-03c892a02568fa8a5765d9fb569a55f17ea05f96.tar.gz
python-smartpm: multilib fixes
To fix some multilib issues, change the way the RPM backend decides if two packages can coexist: if they have a different architecture, automatically assume that they can coexist (which is fundamental for multilib). [YOCTO #3681] (From OE-Core rev: 05fd850f09c58dba8f64f3fe1de28ed9f21890a2) Signed-off-by: Bogdan Marinescu <bogdan.a.marinescu@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python')
-rw-r--r--meta/recipes-devtools/python/python-smartpm/smart-multilib-fixes.patch22
-rw-r--r--meta/recipes-devtools/python/python-smartpm_1.4.1.bb3
2 files changed, 24 insertions, 1 deletions
diff --git a/meta/recipes-devtools/python/python-smartpm/smart-multilib-fixes.patch b/meta/recipes-devtools/python/python-smartpm/smart-multilib-fixes.patch
new file mode 100644
index 0000000000..56fef79a5f
--- /dev/null
+++ b/meta/recipes-devtools/python/python-smartpm/smart-multilib-fixes.patch
@@ -0,0 +1,22 @@
+To fix some multilib issues, change the way the RPM backend decides
+if two packages can coexist: if they have a different architecture,
+automatically assume that they can coexist (which is fundamental for
+multilib).
+
+Upstream-Status: Pending
+
+Signed-off-by: Bogdan Marinescu <bogdan.a.marinescu@intel.com>
+
+diff --git a/smart/backends/rpm/base.py b/smart/backends/rpm/base.py
+index 6e83d40..7140c1b 100644
+--- a/smart/backends/rpm/base.py
++++ b/smart/backends/rpm/base.py
+@@ -228,6 +228,8 @@ class RPMPackage(Package):
+ return False
+ selfver, selfarch = splitarch(self.version)
+ otherver, otherarch = splitarch(other.version)
++ if selfarch != otherarch:
++ return True
+ selfcolor = getArchColor(selfarch)
+ othercolor = getArchColor(otherarch)
+ if (selfcolor and othercolor and selfcolor != othercolor and
diff --git a/meta/recipes-devtools/python/python-smartpm_1.4.1.bb b/meta/recipes-devtools/python/python-smartpm_1.4.1.bb
index 4d0f96b769..06641adc4c 100644
--- a/meta/recipes-devtools/python/python-smartpm_1.4.1.bb
+++ b/meta/recipes-devtools/python/python-smartpm_1.4.1.bb
@@ -11,7 +11,7 @@ LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://LICENSE;md5=393a5ca445f6965873eca0259a17f833"
DEPENDS = "python rpm"
-PR = "r7"
+PR = "r8"
SRCNAME = "smart"
SRC_URI = "\
@@ -25,6 +25,7 @@ SRC_URI = "\
file://smart-tmpdir.patch \
file://smart-metadata-match.patch \
file://smart-improve-error-reporting.patch \
+ file://smart-multilib-fixes.patch \
"
SRC_URI[md5sum] = "573ef32ba177a6b3c4bf7ef04873fcb6"