aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python_2.7.3.bb
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2013-07-19 17:10:59 +0200
committerSaul Wold <sgw@linux.intel.com>2013-07-22 09:44:10 -0700
commita768047cb8fc00ecf13f4db08117c348a9312c47 (patch)
tree3433e57b265f52d31cfccbc87e1bf67932b9ef84 /meta/recipes-devtools/python/python_2.7.3.bb
parent0fcee1d02f98a40f38c622459e8b5ce3d39826ce (diff)
downloadopenembedded-core-a768047cb8fc00ecf13f4db08117c348a9312c47.tar.gz
python: Add ptest
Install python test suite and run it as ptest Signed-off-by: Tudor Florea <tudor.florea@enea.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-devtools/python/python_2.7.3.bb')
-rw-r--r--meta/recipes-devtools/python/python_2.7.3.bb10
1 files changed, 10 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python_2.7.3.bb b/meta/recipes-devtools/python/python_2.7.3.bb
index 59d189d862..2e35da60c4 100644
--- a/meta/recipes-devtools/python/python_2.7.3.bb
+++ b/meta/recipes-devtools/python/python_2.7.3.bb
@@ -28,6 +28,8 @@ SRC_URI += "\
file://builddir.patch \
file://python-2.7.3-CVE-2012-2135.patch \
file://gcc-4.8-fix-configure-Wformat.patch \
+ file://fix-makefile-for-ptest.patch \
+ file://run-ptest \
"
S = "${WORKDIR}/Python-${PV}"
@@ -119,6 +121,11 @@ do_install_append_class-nativesdk () {
create_wrapper ${D}${bindir}/python2.7 TERMINFO_DIRS='${sysconfdir}/terminfo:/etc/terminfo:/usr/share/terminfo:/usr/share/misc/terminfo:/lib/terminfo'
}
+do_install_ptest() {
+ cp ${B}/Makefile ${D}${PTEST_PATH}
+ sed -i s:LIBDIR:${libdir}:g ${D}${PTEST_PATH}/run-ptest
+}
+
SSTATE_SCAN_FILES += "Makefile"
PACKAGE_PREPROCESS_FUNCS += "py_package_preprocess"
@@ -148,6 +155,9 @@ FILES_${PN}-dbg += "${libdir}/python${PYTHON_MAJMIN}/lib-dynload/.debug"
# catch all the rest (unsorted)
PACKAGES += "${PN}-misc"
FILES_${PN}-misc = "${libdir}/python${PYTHON_MAJMIN}"
+RDEPENDS_${PN}-ptest = "${PN}-modules ${PN}-misc"
+#inherit ptest after "require python-${PYTHON_MAJMIN}-manifest.inc" so PACKAGES doesn't get overwritten
+inherit ptest
# catch manpage
PACKAGES += "${PN}-man"