aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python_2.7.3.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2013-06-17 15:57:49 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-06-17 17:02:46 +0100
commit682861166f39fbdcd0c9b923139faab2d40362cf (patch)
tree8fbaeb502bb7fcdba39625eddd5d88b81bd5ca85 /meta/recipes-devtools/python/python_2.7.3.bb
parent4569d7403638e4c1f637e3a6adb8dea620dc8543 (diff)
downloadopenembedded-core-682861166f39fbdcd0c9b923139faab2d40362cf.tar.gz
python: Add nativesdk wrapper to handle terminfo
Currently if you build nativesdk-python, install it and try and run it, you see it search in the default nativesdk path for terminfo files when the readline module is used. If terminfo files cannot be found, or if the ones found are incorrect, the system may emit control characters which confuse commandline processing. This patch sets the TERMINFO_DIRS variable to ensure the correct locations are searched for terminfo files, starting with the nativesdk terminfo files and falling back to the host systtem's. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python_2.7.3.bb')
-rw-r--r--meta/recipes-devtools/python/python_2.7.3.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python_2.7.3.bb b/meta/recipes-devtools/python/python_2.7.3.bb
index 5150e524ae..59d189d862 100644
--- a/meta/recipes-devtools/python/python_2.7.3.bb
+++ b/meta/recipes-devtools/python/python_2.7.3.bb
@@ -115,6 +115,10 @@ do_install() {
oe_multilib_header python${PYTHON_MAJMIN}/pyconfig.h
}
+do_install_append_class-nativesdk () {
+ create_wrapper ${D}${bindir}/python2.7 TERMINFO_DIRS='${sysconfdir}/terminfo:/etc/terminfo:/usr/share/terminfo:/usr/share/misc/terminfo:/lib/terminfo'
+}
+
SSTATE_SCAN_FILES += "Makefile"
PACKAGE_PREPROCESS_FUNCS += "py_package_preprocess"