aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python_2.7.3.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2013-03-19 10:09:38 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-03-19 11:51:00 +0000
commit5704dfa690a625abcface432cf5f9c9bc3ee8abd (patch)
tree4773c8dff522277d55dc18a2c34d57dcea9dc6a2 /meta/recipes-devtools/python/python_2.7.3.bb
parentba748709ff01f9a0ea9b1671d509c971a271ed2f (diff)
downloadopenembedded-core-5704dfa690a625abcface432cf5f9c9bc3ee8abd.tar.gz
python: fix on-target use of distutils/setuptools by removing references to buildpaths
Running 'python setup.py build' would fail due to the python Makefile having CC= i586-angstrom-linux-gcc -m32 -march=core2 -msse3 -mtune=generic -mfpmath=sse --sysroot=/home/koen/v2012.12/build/tmp-angstrom_v2012_12-eglibc/sysroots/fri2 CXX= i586-angstrom-linux-g++ -m32 -march=core2 -msse3 -mtune=generic -mfpmath=sse --sysroot=/home/koen/v2012.12/build/tmp-angstrom_v2012_12-eglibc/sysroots/fri2 '--with-libtool-sysroot=/home/koen/v2012.12/build/tmp-angstrom_v2012_12-eglibc/sysroots/fri2' And more Multiple users have reported this problem: http://hipstercircuits.com/?p=499 http://www.gigamegablog.com/2012/09/09/beaglebone-coding-101-spi-output/ Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python_2.7.3.bb')
-rw-r--r--meta/recipes-devtools/python/python_2.7.3.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python_2.7.3.bb b/meta/recipes-devtools/python/python_2.7.3.bb
index c181933a64..aace95e729 100644
--- a/meta/recipes-devtools/python/python_2.7.3.bb
+++ b/meta/recipes-devtools/python/python_2.7.3.bb
@@ -122,6 +122,9 @@ PACKAGE_PREPROCESS_FUNCS += "py_package_preprocess"
py_package_preprocess () {
# copy back the old Makefile to fix target package
install -m 0644 Makefile.orig ${PKGD}/${libdir}/python${PYTHON_MAJMIN}/config/Makefile
+
+ # Remove references to buildmachine paths in target Makefile
+ sed -i -e 's:--sysroot=${STAGING_DIR_TARGET}::g' -e s:'--with-libtool-sysroot=${STAGING_DIR_TARGET}'::g ${PKGD}/${libdir}/python${PYTHON_MAJMIN}/config/Makefile
}
require python-${PYTHON_MAJMIN}-manifest.inc