aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python_2.7.3.bb
diff options
context:
space:
mode:
authorJackie Huang <jackie.huang@windriver.com>2012-08-04 21:14:08 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-08-06 14:17:22 +0100
commit11267f8a1ccf65142988b095351a84b0fa0fcbcf (patch)
tree1f1ae25b44971fe4fa202ca3f93ca670a932c2d2 /meta/recipes-devtools/python/python_2.7.3.bb
parent662637decc23888c9b0da93807257943bab14583 (diff)
downloadopenembedded-core-11267f8a1ccf65142988b095351a84b0fa0fcbcf.tar.gz
python: Fix to support the python module _bsddb built with db 5.3
_bsddb module in python 2.7 could be built only with db version between 4.1 and 4.7. A patch was added to avoid build warning about this for [YOCTO #1937] but not actually fixed it. This patch enable _bsddb module be built with db 5.3, and remove --disable-statistics from the DB5_CONFIG to fix segmentation fault when using _bsddb module in python. [YOCTO #2749] Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python_2.7.3.bb')
-rw-r--r--meta/recipes-devtools/python/python_2.7.3.bb5
1 files changed, 3 insertions, 2 deletions
diff --git a/meta/recipes-devtools/python/python_2.7.3.bb b/meta/recipes-devtools/python/python_2.7.3.bb
index d27ff05a18..9c648fec15 100644
--- a/meta/recipes-devtools/python/python_2.7.3.bb
+++ b/meta/recipes-devtools/python/python_2.7.3.bb
@@ -1,6 +1,6 @@
require python.inc
DEPENDS = "python-native bzip2 db gdbm openssl readline sqlite3 zlib"
-PR = "${INC_PR}.1"
+PR = "${INC_PR}.2"
DISTRO_SRC_URI ?= "file://sitecustomize.py"
DISTRO_SRC_URI_linuxstdbase = ""
@@ -23,9 +23,10 @@ SRC_URI += "\
file://setuptweaks.patch \
file://check-if-target-is-64b-not-host.patch \
file://search_db_h_in_inc_dirs_and_avoid_warning.patch \
- file://avoid_warning_about_bsddb.patch \
file://avoid_warning_about_tkinter.patch \
file://avoid_warning_for_sunos_specific_module.patch \
+ file://python-2.7.3-berkeley-db-5.3.patch \
+ file://python-2.7.3-remove-bsdb-rpath.patch \
"
S = "${WORKDIR}/Python-${PV}"